diff mbox series

[bug#57594] gnu: Add texlive-latex-pbox.

Message ID 20220905104023.9851-1-wz@freeshell.de
State Accepted
Headers show
Series [bug#57594] gnu: Add texlive-latex-pbox. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wiktor Żelazny Sept. 5, 2022, 10:40 a.m. UTC
From: Wiktor Żelazny <wzelazny@vurv.cz>

* gnu/packages/tex.scm (texlive-latex-pbox): New variable.
---
 gnu/packages/tex.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)


base-commit: 31b4eea5c0d361dfbca119c27cbc1e8c6f65782a

Comments

Christopher Baines Sept. 10, 2022, 10:51 a.m. UTC | #1
Wiktor Żelazny <wz@freeshell.de> writes:

> From: Wiktor Żelazny <wzelazny@vurv.cz>
>
> * gnu/packages/tex.scm (texlive-latex-pbox): New variable.
> ---
>  gnu/packages/tex.scm | 17 +++++++++++++++++
>  1 file changed, 17 insertions(+)

Thanks Wiktor, I've pushed this to master as
fe42befd64df016d755f56107a407f5e4b5c3814.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 56308c4cf9..003f229fb0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6799,6 +6799,23 @@  (define-public texlive-latex-parskip
 designed class) helps alleviate this untidiness.")
     (license license:lppl)))
 
+(define-public texlive-latex-pbox
+  (package
+    (inherit (simple-texlive-package
+              "texlive-latex-pbox"
+              (list "doc/latex/pbox/"
+                    "tex/latex/pbox/")
+              (base32 "0902snjidmhjml01zcppcpp4j6pidin1sdvfi7gnbb5v86zd5f0n")
+              #:trivial? #t))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/pbox")
+    (synopsis "\\parbox with a variable width")
+    (description
+     "@code{pbox} defines a \\pbox{<max width>}{<text>} command which adjusts
+the box width to that of the enclosed text, up to the maximum width given.  The
+package also defines some associated length commands.")
+    (license license:gpl3+)))
+
 (define-public texlive-latex-pdfpages
   (package
     (name "texlive-latex-pdfpages")