diff mbox series

[bug#57592,1/1] gnu: Add texlive-latex-frankenstein.

Message ID 20220905090920.24270-1-wz@freeshell.de
State Accepted
Headers show
Series Add texlive-latex-frankenstein. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wiktor Żelazny Sept. 5, 2022, 9:09 a.m. UTC
From: Wiktor Żelazny <wzelazny@vurv.cz>

* gnu/packages/tex.scm (texlive-latex-frankenstein): New variable.
---
 gnu/packages/tex.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

Comments

Christopher Baines Sept. 10, 2022, 10:52 a.m. UTC | #1
Wiktor Żelazny <wz@freeshell.de> writes:

> From: Wiktor Żelazny <wzelazny@vurv.cz>
>
> * gnu/packages/tex.scm (texlive-latex-frankenstein): New variable.
> ---
>  gnu/packages/tex.scm | 39 +++++++++++++++++++++++++++++++++++++++
>  1 file changed, 39 insertions(+)

Thanks Wiktor, I did have a look at this, but I think it would be useful
if someone more familiar with texlive stuff in Guix had a look as well.

Given this is some kind of combination of bits, some of which may
already be in Guix, I'm a bit hesitant about whether it's a good fit as
is.

Chris
Ludovic Courtès Sept. 24, 2022, 1:09 p.m. UTC | #2
Hi,

Christopher Baines <mail@cbaines.net> skribis:

> Wiktor Żelazny <wz@freeshell.de> writes:
>
>> From: Wiktor Żelazny <wzelazny@vurv.cz>
>>
>> * gnu/packages/tex.scm (texlive-latex-frankenstein): New variable.
>> ---
>>  gnu/packages/tex.scm | 39 +++++++++++++++++++++++++++++++++++++++
>>  1 file changed, 39 insertions(+)
>
> Thanks Wiktor, I did have a look at this, but I think it would be useful
> if someone more familiar with texlive stuff in Guix had a look as well.
>
> Given this is some kind of combination of bits, some of which may
> already be in Guix, I'm a bit hesitant about whether it's a good fit as
> is.

Apparently some (or all?) of the packages mentioned in the description
are unavailable in Guix, and I wonder if they’re in TeX Live.

So I went ahead and applied it.  We can always remove it later if/when
the individual packages are added.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 56308c4cf9..4123ab9d94 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6171,6 +6171,45 @@  (define-public texlive-latex-footmisc
 footnotes with symbols rather than numbers.")
     (license license:lppl1.3+)))
 
+(define-public texlive-latex-frankenstein
+  (package
+    (name "texlive-latex-frankenstein")
+    (version (number->string %texlive-revision))
+    (source (origin
+              (method svn-fetch)
+              (uri (svn-reference (url (string-append
+                                        "svn://www.tug.org/texlive/tags/"
+                                        %texlive-tag "/Master/texmf-dist/"
+                                        "/tex/latex/frankenstein"))
+                                  (revision %texlive-revision)))
+              (file-name (string-append name "-" version "-checkout"))
+              (sha256
+               (base32
+                "1zhdvn3zgdarlzfcyq8nzilvw0v0bqgl4m0y7j233cbqw8wiil4z"))))
+    (build-system trivial-build-system)
+    (arguments
+     `(#:modules ((guix build utils))
+       #:builder (begin
+                   (use-modules (guix build utils))
+                   (let ((target (string-append (assoc-ref %outputs "out")
+                                  "/share/texmf-dist/tex/latex/frankenstein")))
+                     (mkdir-p target)
+                     (copy-recursively (assoc-ref %build-inputs "source")
+                                       target) #t))))
+    (home-page "https://ctan.org/pkg/frankenstein")
+    (synopsis "Collection of unrelated LaTeX packages")
+    (description
+     "Frankenstein is a bundle of LaTeX packages serving various purposes and a
+BibTeX bibliography style.  The individual packages are: @code{abbrevs},
+@code{achicago}, @code{achicago} bibstyle, @code{attrib}, @code{blkcntrl},
+@code{compsci}, @code{dialogue}, @code{lips}, @code{moredefs}, @code{newclude},
+@code{slemph} and @code{titles}.  Note: The installation follows the suboptimal
+``Quick and dirty'' recipe, rendering some features unavailable.")
+    ;; README mentions an unspecified version of GNU GPL and points to COPYING,
+    ;; which is missing. However, the individual files mention LPPL 1.2 or
+    ;; later.
+    (license license:lppl1.2+)))
+
 (define-public texlive-latex-letltxmacro
   (package
     (inherit (simple-texlive-package