diff mbox series

[bug#57560,4/4] gnu: hashcat: Fix cross-compilation.

Message ID 20220903120827.25648-4-maximedevos@telenet.be
State Accepted
Headers show
Series Fix multiple hashcat issue. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

M Sept. 3, 2022, 12:08 p.m. UTC
* gnu/packages/password-utils.scm
(hashcat)[native-inputs]: Move to ...
(hashcat)[inputs]: ... here.
(hashcat)[arguments]<#:make-flags>: Set AR and CC.
---
 gnu/packages/password-utils.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 172f633449..f92c47d539 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -1110,8 +1110,8 @@  (define-public pass-rotate
 your online accounts makes it necessary.")
     (license license:expat)))
 
-;; XXX: move this import upwards before merging this patch
-(use-modules (gnu packages digest))
+;; XXX: move these imports upwards before merging this patch
+(use-modules (gnu packages digest) (guix utils))
 (define-public hashcat
   (package
     (name "hashcat")
@@ -1130,13 +1130,13 @@  (define-public hashcat
         ;; TODO: Unbundle LZMA-SDK as well
         #~(for-each delete-file-recursively
                     '("deps/zlib" "deps/xxHash" "deps/OpenCL-Headers")))))
-    (native-inputs
-     (list opencl-headers))
-    (inputs (list minizip xxhash zlib))
+    (inputs (list minizip opencl-headers xxhash zlib))
     (build-system gnu-build-system)
     (arguments
      (list #:tests? #f ;no tests
-           #:make-flags #~(list (string-append "PREFIX="
+           #:make-flags #~(list (string-append "AR=" #$(ar-for-target))
+                                (string-append "CC=" #$(cc-for-target))
+                                (string-append "PREFIX="
                                                #$output)
                                 (string-append "USE_SYSTEM_ZLIB=1")
                                 (string-append "USE_SYSTEM_OPENCL=1")