diff mbox series

[bug#57549] gnu: Add comments to the bottom of a few package modules.

Message ID 20220902190144.16221-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#57549] gnu: Add comments to the bottom of a few package modules. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Christopher Baines Sept. 2, 2022, 7:01 p.m. UTC
This will hopefully discourage patches which add new packages to the bottom of
files, as this increases the likelyhood of conflicts when applying patches.
---
 gnu/packages/python-science.scm | 5 +++++
 gnu/packages/python-xyz.scm     | 5 +++++
 gnu/packages/ruby.scm           | 5 +++++
 gnu/packages/tex.scm            | 5 +++++
 4 files changed, 20 insertions(+)

Comments

M Sept. 2, 2022, 7:05 p.m. UTC | #1
On 02-09-2022 21:01, Christopher Baines wrote:
> This will hopefully discourage patches which add new packages to the bottom of
> files, as this increases the likelyhood of conflicts when applying patches.
> ---
>   gnu/packages/python-science.scm | 5 +++++
>   gnu/packages/python-xyz.scm     | 5 +++++
>   gnu/packages/ruby.scm           | 5 +++++
>   gnu/packages/tex.scm            | 5 +++++
>   4 files changed, 20 insertions(+)

crates-io.scm could benefit from such lines as well.

Sounds useful, LGTM.

Greetings,
Maxime.
Ludovic Courtès Sept. 8, 2022, 2:20 p.m. UTC | #2
Hi,

Christopher Baines <mail@cbaines.net> skribis:

> This will hopefully discourage patches which add new packages to the bottom of
> files, as this increases the likelyhood of conflicts when applying patches.

Please mention the modified files here.

> +;;;
> +;;; Avoid adding new packages to the end of this file. Place them above by

Maybe start with “To reduce the chances of a merge conflict, avoid […]”?

Anyway, LGTM!

Ludo’.
Christopher Baines Sept. 10, 2022, 10:43 a.m. UTC | #3
Ludovic Courtès <ludo@gnu.org> writes:

> Christopher Baines <mail@cbaines.net> skribis:
>
>> This will hopefully discourage patches which add new packages to the bottom of
>> files, as this increases the likelyhood of conflicts when applying patches.
>
> Please mention the modified files here.

Done.

>> +;;;
>> +;;; Avoid adding new packages to the end of this file. Place them above by
>
> Maybe start with “To reduce the chances of a merge conflict, avoid […]”?

I've added this in the second sentence, since I want to keep the
instruction first as this might make it harder to skip over and ignore.

> Anyway, LGTM!

Thanks Ludo and Maxime, pushed this as
fe42befd64df016d755f56107a407f5e4b5c3814.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 95f60aae7b..1c165aa1de 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1478,3 +1478,8 @@  (define-public python-opt-einsum
 well as potentially any library which conforms to a standard API. See the
 documentation for more information.")
     (license license:expat)))
+
+;;;
+;;; Avoid adding new packages to the end of this file. Place them above by
+;;; existing packages with similar functionality or similar names.
+;;;
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b058704172..e0e144de29 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30738,3 +30738,8 @@  (define-public python-lief
      "@code{python-lief} is a cross platform library which can parse, modify
 and abstract ELF, PE and MachO formats.")
     (license license:asl2.0)))
+
+;;;
+;;; Avoid adding new packages to the end of this file. Place them above by
+;;; existing packages with similar functionality or similar names.
+;;;
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 94c3bfeb6f..a0c3990b98 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -13766,3 +13766,8 @@  (define (run-with-output-file file command . args)
 has not yet been packaged for Guix.")
     (license license:bsd-2)
     (properties `((upstream-name . "anystyle-cli")))))
+
+;;;
+;;; Avoid adding new packages to the end of this file. Place them above by
+;;; existing packages with similar functionality or similar names.
+;;;
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 212c7eb4a9..c09bae4303 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11572,3 +11572,8 @@  (define-public texlive-sourcecodepro
 Adobe in both Adobe Type 1 and OpenType formats, plus macros supporting the
 use of the fonts in LaTeX (Type 1) and XeLaTeX/LuaLaTeX (OTF).")
     (license (list license:lppl1.3+ license:silofl1.1))))
+
+;;;
+;;; Avoid adding new packages to the end of this file. Place them above by
+;;; existing packages with similar functionality or similar names.
+;;;