diff mbox series

[bug#57542,2/2] gnu: Add ruby-pry-doc.

Message ID 20220902090314.8215-3-higashi@taiju.info
State Accepted
Headers show
Series Add ruby-pry-doc | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Taiju HIGASHI Sept. 2, 2022, 9:03 a.m. UTC
* gnu/packages/ruby.scm (ruby-pry-doc): New variable.
---
 gnu/packages/ruby.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d658581ed0..94c3bfeb6f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5440,6 +5440,29 @@  (define-public ruby-pry
     (home-page "https://cobaltbluemedia.com/pryrepl/")
     (license license:expat)))
 
+(define-public ruby-pry-doc
+  (package
+    (name "ruby-pry-doc")
+    (version "1.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "pry-doc" version))
+              (sha256
+               (base32
+                "0wyvql6pb6m8jl8bsamabxhxhd86bnqblspaxzz05sl0fm2ynj0r"))))
+    (build-system ruby-build-system)
+    (propagated-inputs (list ruby-pry ruby-yard))
+    (native-inputs (list ruby-latest-ruby ruby-rspec ruby-rake)) ;for tests
+    (synopsis "Provides YARD and extended documentation support for Pry")
+    (description
+     "Pry Doc is a Pry REPL plugin.  It provides extended documentation
+support for the REPL by means of improving the @code{show-doc} and
+@code{show-source} commands.  With help of the plugin the commands are
+be able to display the source code and the docs of Ruby methods and
+classes implemented in C.")
+    (home-page "https://github.com/pry/pry-doc")
+    (license license:expat)))
+
 (define-public ruby-single-cov
   (package
     (name "ruby-single-cov")