diff mbox series

[bug#57541] gnu: Add texlive-latex-newfloat.

Message ID 20220902075122.32140-1-wz@freeshell.de
State Accepted
Headers show
Series [bug#57541] gnu: Add texlive-latex-newfloat. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wiktor Żelazny Sept. 2, 2022, 7:51 a.m. UTC
From: Wiktor Żelazny <wzelazny@vurv.cz>

* gnu/packages/tex.scm (texlive-latex-newfloat): New variable.
---
 gnu/packages/tex.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)


base-commit: bd638a8ad6140db87851a86faae89e736e148f3d

Comments

Christopher Baines Sept. 2, 2022, 6:57 p.m. UTC | #1
Wiktor Żelazny <wz@freeshell.de> writes:

> From: Wiktor Żelazny <wzelazny@vurv.cz>
>
> * gnu/packages/tex.scm (texlive-latex-newfloat): New variable.
> ---
>  gnu/packages/tex.scm | 17 +++++++++++++++++
>  1 file changed, 17 insertions(+)

Thanks Wiktor, I've moved this package futher up the file and pushed as
34766a6631c97af0f13af6c16e1c9d26780e5cb5.

For future reference, I'd avoid adding new packages to the bottom of
modules, because it often caused conflicts with other changes adding new
packages. For example, this patch conflicts with the other texlive
packages you've submitted, probably because you're adding the new
packages at the bottom of the file.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1b3c086d54..4dd9082ed0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11555,3 +11555,20 @@  (define-public texlive-sourcecodepro
 Adobe in both Adobe Type 1 and OpenType formats, plus macros supporting the
 use of the fonts in LaTeX (Type 1) and XeLaTeX/LuaLaTeX (OTF).")
     (license (list license:lppl1.3+ license:silofl1.1))))
+
+(define-public texlive-latex-newfloat
+  (package
+    (inherit (simple-texlive-package
+              "texlive-latex-newfloat"
+              (list "doc/latex/newfloat/"
+                    "tex/latex/newfloat/")
+              (base32 "1047max3li9ni15njgsvc7qglakgrjy2l0s72imgzdmwgb2h8jyf")
+              #:trivial? #t))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/newfloat")
+    (synopsis "Define new floating environments")
+    (description
+     "This package offers the command @code{\\DeclareFloatingEnvironment},
+which the user may use to define new floating environments which behave like
+the LaTeX standard foating environments @code{figure} and @code{table}.")
+    (license license:lppl)))