diff mbox series

[bug#57538] gnu: Add texlive-latex-hyphenat.

Message ID 20220902055604.14324-1-wz@freeshell.de
State Accepted
Headers show
Series [bug#57538] gnu: Add texlive-latex-hyphenat. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wiktor Żelazny Sept. 2, 2022, 5:56 a.m. UTC
From: Wiktor Żelazny <wzelazny@vurv.cz>

* gnu/packages/tex.scm (texlive-latex-hyphenat): New variable.
---
 gnu/packages/tex.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)


base-commit: bd638a8ad6140db87851a86faae89e736e148f3d

Comments

Ludovic Courtès Sept. 4, 2022, 9:10 p.m. UTC | #1
Hi,

Wiktor Żelazny <wz@freeshell.de> skribis:

> From: Wiktor Żelazny <wzelazny@vurv.cz>
>
> * gnu/packages/tex.scm (texlive-latex-hyphenat): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1b3c086d54..7a96a38cb6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11555,3 +11555,22 @@  (define-public texlive-sourcecodepro
 Adobe in both Adobe Type 1 and OpenType formats, plus macros supporting the
 use of the fonts in LaTeX (Type 1) and XeLaTeX/LuaLaTeX (OTF).")
     (license (list license:lppl1.3+ license:silofl1.1))))
+
+(define-public texlive-latex-hyphenat
+  (package
+    (inherit (simple-texlive-package
+              "texlive-latex-hyphenat"
+              (list "doc/latex/hyphenat/"
+                    "tex/latex/hyphenat/")
+              (base32 "0b3jx2yvryx95am0ll9h6yc99niw2lwgsbq7r89j84z2qyp2llsq")
+              #:trivial? #t))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/hyphenat")
+    (synopsis "Disable/enable hyphenation")
+    (description
+     "This package can disable all hyphenation or enable hyphenation of
+non-alphabetics or monospaced fonts.  The package can also enable hyphenation
+within ‘words’ that contain non-alphabetic characters (e.g., that include
+underscores), and hyphenation of text typeset in monospaced (e.g., cmtt)
+fonts.")
+    (license license:lppl1.3c+)))