diff mbox series

[bug#57517] gnu: Add texlive-latex-lastpage.

Message ID 20220901093804.18480-1-wz@freeshell.de
State Accepted
Headers show
Series [bug#57517] gnu: Add texlive-latex-lastpage. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wiktor Żelazny Sept. 1, 2022, 9:38 a.m. UTC
From: Wiktor Żelazny <wzelazny@vurv.cz>

* gnu/packages/tex.scm (texlive-latex-lastpage): New variable.
---
 gnu/packages/tex.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)


base-commit: 4a5fbadb88ff18bb7de87b351c6009aaa398a892

Comments

Ludovic Courtès Sept. 8, 2022, 1:47 p.m. UTC | #1
Wiktor Żelazny <wz@freeshell.de> skribis:

> From: Wiktor Żelazny <wzelazny@vurv.cz>
>
> * gnu/packages/tex.scm (texlive-latex-lastpage): New variable.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1b3c086d54..3f98f5264e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11555,3 +11555,21 @@  (define-public texlive-sourcecodepro
 Adobe in both Adobe Type 1 and OpenType formats, plus macros supporting the
 use of the fonts in LaTeX (Type 1) and XeLaTeX/LuaLaTeX (OTF).")
     (license (list license:lppl1.3+ license:silofl1.1))))
+
+(define-public texlive-latex-lastpage
+  (package
+    (inherit (simple-texlive-package
+              "texlive-latex-lastpage"
+              (list "doc/latex/lastpage/"
+                    "tex/latex/lastpage/")
+              (base32 "0q6x743b8fkw9r82lrxy49f9xsg81bffynwvpnvpnp3h4mkafvdb")
+              #:trivial? #t))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/lastpage")
+    (synopsis "Reference last page for Page N of M type footers")
+    (description
+     "This package enables referencing the number of pages in a LaTeX document
+through the introduction of a new label which can be referenced like
+@code{\\pageref{LastPage}} to give a reference to the last page of a document.
+It is particularly useful in the page footer that says: Page N of M.")
+    (license license:lppl1.3c+)))