diff mbox series

[bug#57497] gnu: Add blueprint-compiler

Message ID 20220831181845.19359-1-ahriman@fedora.email
State Accepted
Headers show
Series [bug#57497] gnu: Add blueprint-compiler | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Ahriman Aug. 31, 2022, 6:18 p.m. UTC
* gnu/packages/gnome.scm (blueprint-compiler): New variable.
---
It seems gtk was the only dependency missing. Or maybe im building all wrong.

 gnu/packages/gnome.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Ludovic Courtès Sept. 6, 2022, 2:46 p.m. UTC | #1
Hi,

Ahriman <ahriman@fedora.email> skribis:

> * gnu/packages/gnome.scm (blueprint-compiler): New variable.

I passed it through ‘guix style’ and applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 251d08ae01..042f009337 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3204,6 +3204,32 @@  (define-public glade3
                                 (variable "GLADE_MODULE_SEARCH_PATH")
                                 (files '("lib/glade/modules")))))))
 
+(define-public blueprint-compiler
+  (let ((commit "87cedc2c7e48b01dc1b07aef937e2fe02111b18c"))
+    (package
+     (name "blueprint-compiler")
+     (version "0.2.0")
+     (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.gnome.org/jwestman/blueprint-compiler")
+                    (commit commit)))
+              (file-name (string-append name "-" commit "-checkout"))
+              (sha256
+               (base32
+                "1mrj5dyjf5d325yc28fpph588qfsz6bm2nx5nnsgcv02bagplxid"))))
+     (build-system meson-build-system)
+     (native-inputs (list
+                     gobject-introspection
+                     gtk))
+     (inputs (list python))
+     (synopsis "Template markup language")
+     (description
+      "Blueprint is a markup language for GTK user interfaces.  Internally, it
+compiles to GTKBuilder XML.")
+     (home-page "https://gitlab.gnome.org/jwestman/blueprint-compiler")
+     (license license:lgpl3+))))
+
 (define-public cambalache
   (package
    (name "cambalache")