diff mbox series

[bug#57351,v2] gnu: Add vpn-slice.

Message ID 20220829185058.32439-1-arunisaac@systemreboot.net
State Accepted
Headers show
Series [bug#57351,v2] gnu: Add vpn-slice. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Arun Isaac Aug. 29, 2022, 6:50 p.m. UTC
* gnu/packages/vpn.scm (vpn-slice): New variable.
---
 gnu/packages/vpn.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Efraim Flashner Aug. 30, 2022, 6:38 p.m. UTC | #1
Looks good to me!

On Tue, Aug 30, 2022 at 12:20:58AM +0530, Arun Isaac wrote:
> * gnu/packages/vpn.scm (vpn-slice): New variable.
> ---
>  gnu/packages/vpn.scm | 28 ++++++++++++++++++++++++++++
>  1 file changed, 28 insertions(+)
> 
> diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
> index 1ec619b0c2..c5c5939996 100644
> --- a/gnu/packages/vpn.scm
> +++ b/gnu/packages/vpn.scm
> @@ -1197,3 +1197,31 @@ (define-public xl2tpd
>       "xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661).
>  L2TP allows you to tunnel PPP over UDP.")
>      (license license:gpl2)))
> +
> +(define-public vpn-slice
> +  (package
> +    (name "vpn-slice")
> +    (version "0.16.1")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "vpn-slice" version))
> +              (sha256
> +               (base32
> +                "1anfx4hn2ggm6sbwqmqx68s3l2rjcy4z4l038xqb440jnk8jvl18"))))
> +    (build-system python-build-system)
> +    (inputs (list python-dnspython python-setproctitle))
> +    (home-page "https://github.com/dlenski/vpn-slice")
> +    (synopsis "Split tunneling replacement for vpnc-script")
> +    (description "vpn-slice is a replacement for @command{vpnc-script} used by
> +@code{openconnect} and @code{vpnc}.  Instead of trying to copy the behavior of
> +standard corporate VPN clients, which normally reroute all your network
> +traffic through the VPN, vpn-slice tries to minimize your contact with an
> +intrusive VPN.  This is also known as a split-tunnel VPN, since it splits your
> +traffic between the VPN tunnel and your normal network interfaces.
> +
> +By default, vpn-slice only routes traffic for specific hosts or subnets
> +through the VPN.  It automatically looks up named hosts, using the VPN's DNS
> +servers, and adds entries for them to your @file{/etc/hosts} (which it cleans
> +up after VPN disconnection), however it does not otherwise alter your
> +@file{/etc/resolv.conf} at all.")
> +    (license license:gpl3+)))
> -- 
> 2.37.1
>
Arun Isaac Aug. 31, 2022, 1:15 p.m. UTC | #2
Pushed, thanks for the review!
diff mbox series

Patch

diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 1ec619b0c2..c5c5939996 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -1197,3 +1197,31 @@  (define-public xl2tpd
      "xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661).
 L2TP allows you to tunnel PPP over UDP.")
     (license license:gpl2)))
+
+(define-public vpn-slice
+  (package
+    (name "vpn-slice")
+    (version "0.16.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "vpn-slice" version))
+              (sha256
+               (base32
+                "1anfx4hn2ggm6sbwqmqx68s3l2rjcy4z4l038xqb440jnk8jvl18"))))
+    (build-system python-build-system)
+    (inputs (list python-dnspython python-setproctitle))
+    (home-page "https://github.com/dlenski/vpn-slice")
+    (synopsis "Split tunneling replacement for vpnc-script")
+    (description "vpn-slice is a replacement for @command{vpnc-script} used by
+@code{openconnect} and @code{vpnc}.  Instead of trying to copy the behavior of
+standard corporate VPN clients, which normally reroute all your network
+traffic through the VPN, vpn-slice tries to minimize your contact with an
+intrusive VPN.  This is also known as a split-tunnel VPN, since it splits your
+traffic between the VPN tunnel and your normal network interfaces.
+
+By default, vpn-slice only routes traffic for specific hosts or subnets
+through the VPN.  It automatically looks up named hosts, using the VPN's DNS
+servers, and adds entries for them to your @file{/etc/hosts} (which it cleans
+up after VPN disconnection), however it does not otherwise alter your
+@file{/etc/resolv.conf} at all.")
+    (license license:gpl3+)))