diff mbox series

[bug#57463] gnu: gnupg: Use mirror URL.

Message ID 20220828151544.18341-1-maximedevos@telenet.be
State Accepted
Headers show
Series [bug#57463] gnu: gnupg: Use mirror URL. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

M Aug. 28, 2022, 3:15 p.m. UTC
In commit 38747a27f36dbaadadb1399ec085d88e48c97555, the package switched from
a mirror:// URL to a ftp:// URL, but there doesn't appear to have been any
particular reason for that.

* gnu/packages/gnupg.scm (gnupg)[source]{uri}: Use a mirror:// again.
---
 gnu/packages/gnupg.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: d519305d83d08058e4def2c4d72fe62102d9599d
prerequisite-patch-id: 62949e6148bb8aae2f792aaf4d54f2a136351d28
prerequisite-patch-id: 72191ec47cb3876c5fcd6233880dea7dfc1b165f
prerequisite-patch-id: bbfd96d673e491ddd684e8270c90347547dceaa5
prerequisite-patch-id: fbdac7446d0c3f529f313f89cb9ba975d469d7ac
prerequisite-patch-id: d0a5804a92d868c5ee6726e6e0555a8af25e442c
prerequisite-patch-id: 265c6a618a5000095a68e98abbeb38ce9d1495b6
prerequisite-patch-id: 0db90e763ccb5677aafbbdd97d206add4f344a14
prerequisite-patch-id: 98bedf26708ec6aa7e20194def1595db8407feb7
prerequisite-patch-id: cd6e916ac5253c5189791b93e7151c823cabb94a
prerequisite-patch-id: 85b205826ad93c031293130f8f7be94d67d367a0
prerequisite-patch-id: b8a29ff68d54d845191040a3c3ab60b4de482680
prerequisite-patch-id: ddb3c1afc7288cb51599e680301a4562851fd0c0
prerequisite-patch-id: e35c9f0c09d77a8388fc4082ae3e8b2cf17d9d02
prerequisite-patch-id: d9c713f93f2ec421d14aeafa428524ab16c7b7d0
prerequisite-patch-id: 1dd1a34e6b924be7fd6aa6c0817a1642c22e50e1
prerequisite-patch-id: 40648c94c344a58ff5bccd5f6896e674e6940aa3
prerequisite-patch-id: 4b2d080323b800ec2eb9b4b7946877aa6b7be558
prerequisite-patch-id: 3e8bdf841eab5e25e23c8a7216e55f8a340b1698
prerequisite-patch-id: 1ffae5492851b9484051cad72dede08010aaa3f6
prerequisite-patch-id: 0b9a1695e9162f147c8d5e6562ca79eb30ee9948
prerequisite-patch-id: 1e8c6f7b97cbd01ae7f0bdf73e4b4ca9fdfe65a5
prerequisite-patch-id: bce87ff493c16be3d8f1f90f2eff2988ce8ea968
prerequisite-patch-id: 0a15a3d4ed22634ba9fe513d654f252d0b019d40
prerequisite-patch-id: 187b71b5c874694400734fce47987988ebec0b92
prerequisite-patch-id: bfda1b7fe9f196de24f20d272d04ef8959d66c45
prerequisite-patch-id: 0190c927b0f7d860782572dd9f0e0fd5bb67c881

Comments

Marius Bakke Aug. 29, 2022, 4:04 p.m. UTC | #1
Maxime Devos <maximedevos@telenet.be> skriver:

> In commit 38747a27f36dbaadadb1399ec085d88e48c97555, the package switched from
> a mirror:// URL to a ftp:// URL, but there doesn't appear to have been any
> particular reason for that.

The updater has a tendency to change the URI from mirror:// to the
resolved URL, which can be easy to miss when staging the patch.

(it would be nice to fix that bug)

> * gnu/packages/gnupg.scm (gnupg)[source]{uri}: Use a mirror:// again.

Applied, thanks!
M Aug. 31, 2022, 6:41 p.m. UTC | #2
On 29-08-2022 18:04, Marius Bakke wrote:
> Maxime Devos <maximedevos@telenet.be> skriver:
>
>> In commit 38747a27f36dbaadadb1399ec085d88e48c97555, the package switched from
>> a mirror:// URL to a ftp:// URL, but there doesn't appear to have been any
>> particular reason for that.
> The updater has a tendency to change the URI from mirror:// to the
> resolved URL, which can be easy to miss when staging the patch.
>
> (it would be nice to fix that bug)

I've made a report at #57477, patches are WIP (and not yet sent).

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 08fa1570d6..a1636a205a 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -287,7 +287,7 @@  (define-public gnupg
     (version "2.2.32")
     (source (origin
               (method url-fetch)
-              (uri (string-append "ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-" version
+              (uri (string-append "mirror://gnupg/gnupg/gnupg-" version
                                   ".tar.bz2"))
               (patches (search-patches "gnupg-default-pinentry.patch"))
               (sha256