diff mbox series

[bug#57461] gnu: rr: Update to 5.6.0.

Message ID 20220828135823.7517-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#57461] gnu: rr: Update to 5.6.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder Aug. 28, 2022, 1:58 p.m. UTC
* gnu/packages/debug.scm (rr): Update to 5.6.0.
[arguments]<#:configure-flags>: Add -rpath to zlib to satisfy
validate-runpath.
[inputs]: Add zlib.
---
 gnu/packages/debug.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

Comments

Marius Bakke Aug. 29, 2022, 4 p.m. UTC | #1
Michael Rohleder <mike@rohleder.de> skriver:

> * gnu/packages/debug.scm (rr): Update to 5.6.0.
> [arguments]<#:configure-flags>: Add -rpath to zlib to satisfy
> validate-runpath.
> [inputs]: Add zlib.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 80685900eb..b3ddfbdee6 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -621,7 +621,7 @@  (define-public remake
 (define-public rr
   (package
     (name "rr")
-    (version "5.5.0")
+    (version "5.6.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -629,7 +629,7 @@  (define-public rr
                     (commit version)))
               (sha256
                (base32
-                "079x891axkiy8qbvjar9vbaldlx7pm9p0i3nq6infdc66nc69635"))
+                "0sdpsd7bcbmx9gmp7lv71znzxz708wm8qxq5apbyc6hh80z4fzqz"))
               (file-name (git-file-name name version))))
     (build-system cmake-build-system)
     (arguments
@@ -641,7 +641,9 @@  (define-public rr
              ;; Satisfy the ‘validate-runpath’ phase.  This isn't a direct
              ;; consequence of clearing CMAKE_INSTALL_RPATH.
              (string-append "-DCMAKE_EXE_LINKER_FLAGS=-Wl,-rpath="
-                            (assoc-ref %build-inputs "capnproto") "/lib")
+                            (assoc-ref %build-inputs "capnproto")
+                            "/lib,-rpath=" (assoc-ref %build-inputs "zlib")
+                            "/lib")
              ,@(if (and (not (%current-target-system))
                         (member (%current-system)
                                 '("x86_64-linux" "aarch64-linux")))
@@ -666,7 +668,7 @@  (define-public rr
     (native-inputs
      (list pkg-config ninja which))
     (inputs
-     (list gdb capnproto python python-pexpect))
+     (list gdb capnproto python python-pexpect zlib))
     (home-page "https://rr-project.org/")
     (synopsis "Record and reply debugging framework")
     (description