diff mbox series

[bug#57416] gnu: Add gnudatalanguage.

Message ID 20220825193833.1157970-1-antero@mailbox.org
State New
Headers show
Series [bug#57416] gnu: Add gnudatalanguage. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Antero Mejr Aug. 25, 2022, 7:38 p.m. UTC
* gnu/packages/maths.scm (gnudatalanguage): New variable.
---
Depends on eccodes, patch #57410
https://issues.guix.gnu.org/57410

 gnu/packages/maths.scm | 51 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 51 insertions(+)

Comments

Sharlatan Hellseher Dec. 13, 2022, 10:56 a.m. UTC | #1
Hi,

GDL is very nice project to have in Guix Asto belt, there is a large chain
which depends on IDL (commercial version) but could be compiled with GDL.

PLPlot was in a queue to review for a long time as it needs more love for
packaging all components and adjust configure to detect all of the inputs.
https://issues.guix.gnu.org/46160

I've got some progress on it but it still not picking up most of the inputs.
https://git.sr.ht/~hellseher/ffab/tree/wip-maths/item/ffab/packages/maths.scm#L56

Regards,
Oleg

-- 
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Sharlatan Hellseher Feb. 2, 2023, 11:58 p.m. UTC | #2
Hi Guix team,

Upping this issue as GDL is a nice tool (widely used in astronomy) and
Libre replacement of commercial IDL

Related paaper:
https://joss.theoj.org/papers/10.21105/joss.04633

Regards,
Oleg


-- 
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Simon Tournier Feb. 17, 2023, 5:14 p.m. UTC | #3
Hi,

CC: team science

Thanks for this patch.

On jeu., 25 août 2022 at 15:38, Antero Mejr via Guix-patches via <guix-patches@gnu.org> wrote:

> +    (license license:gpl2)))

Since GDL is a piece of software, maybe the license of GDL is not only
GPL version 2.  For instance, according to Debian, it reads:

https://metadata.ftp-master.debian.org/changelogs//main/g/gnudatalanguage/gnudatalanguage_0.9.9-13_copyright

Well, WDYT?


Cheers,
simon
Andreas Enge Feb. 18, 2023, 10:01 a.m. UTC | #4
Hello,

Am Fri, Feb 17, 2023 at 06:14:24PM +0100 schrieb Simon Tournier:
> Since GDL is a piece of software, maybe the license of GDL is not only
> GPL version 2.  For instance, according to Debian, it reads:
> https://metadata.ftp-master.debian.org/changelogs//main/g/gnudatalanguage/gnudatalanguage_0.9.9-13_copyright

looking at this page, the combined licenses combine to gpl2+.
I do not think it is necessary to be as detailed as Debian in our
poor little license field, so would add the "+" to the patch.

Andreas
Sharlatan Hellseher Oct. 12, 2023, 11:48 p.m. UTC | #5
Hi,

I can help with adjusting this patch set if it would help.

Regards,
Oleg
Ludovic Courtès Dec. 22, 2023, 4:17 p.m. UTC | #6
Hello,

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

> I can help with adjusting this patch set if it would help.

Yes, please!  Looks almost ready.

Thanks,
Ludo’.
Sharlatan Hellseher April 13, 2024, 10:16 p.m. UTC | #7
Hi,

I've applied license modification raised by Andreas. A new module is
added - data-language.scm as the project contains IDE and future
expansion. The main reasoning - it's a new language compiler which would
not fit math.scm module.

Pushed as 2006874c2b..56549cad7c to master.
--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 72d5e9a83a..f276b72697 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -98,6 +98,7 @@  (define-module (gnu packages maths)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
+  #:use-module (gnu packages c)
   #:use-module (gnu packages check)
   #:use-module (gnu packages cmake)
   #:use-module (gnu packages compression)
@@ -116,8 +117,10 @@  (define-module (gnu packages maths)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages gd)
+  #:use-module (gnu packages geo)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages graph)
   #:use-module (gnu packages graphviz)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages icu4c)
@@ -7823,3 +7826,51 @@  (define-public optizelle
 provided for applications written in C++ and Python.  Parallel
 computation is supported via MPI.")
     (license license:bsd-2))))
+
+(define-public gnudatalanguage
+  (package
+    (name "gnudatalanguage")
+    (version "1.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/gnudatalanguage/gdl")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1bb3nin3qrzx2dwdk08vffp4bblrcpv6vv1ybaj499qhqcpqpc12"))))
+    (build-system cmake-build-system)
+    (native-inputs (list python python-numpy))
+    (inputs (list eccodes
+                  eigen
+                  expat
+                  fftw
+                  fftwf
+                  glpk
+                  graphicsmagick
+                  gsl
+                  hdf4-alt
+                  hdf5
+                  libgeotiff
+                  libjpeg-turbo
+                  libpng
+                  libtiff
+                  libtirpc
+                  ncurses
+                  netcdf
+                  plplot
+                  proj
+                  readline
+                  shapelib
+                  udunits
+                  wxwidgets
+                  zlib))
+    (home-page "https://gnudatalanguage.github.io/")
+    (synopsis "Compiler for GDL, an IDL-compatible programming language")
+    (description "GDL (GNU Data Language) is an incremental compiler compatible
+with IDL (Interactive Data Language) and to some extent with PV-WAVE.  Together
+with its library routines it serves as a tool for data analysis and
+visualization in such disciplines as astronomy, geosciences and medical
+imaging.")
+    (license license:gpl2)))