diff mbox series

[bug#57389,06/29] gnu: Rename editorconfig-vim to vim-editorconfig.

Message ID 20220824170856.7776-6-paren@disroot.org
State New
Headers show
Series Vim plugin additions and updates | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( Aug. 24, 2022, 5:08 p.m. UTC
* gnu/packages/vim.scm (vim-editorconfig): Rename from editorconfig-vim.
Improve description. Modernize formatting.
(editorconfig-vim): Deprecate in favour of vim-editorconfig.
---
 gnu/packages/vim.scm | 44 ++++++++++++++++++++++----------------------
 1 file changed, 22 insertions(+), 22 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 53ab5c9d72..180e1b4dce 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -611,35 +611,35 @@  (define-public vim-solarized
 switching between the light and dark background modes.")
       (license license:expat))))
 
-(define-public editorconfig-vim
+(define-public vim-editorconfig
   (package
-    (name "editorconfig-vim")
+    (name "vim-editorconfig")
     (version "1.1.1")
-    (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-               (url "https://github.com/editorconfig/editorconfig-vim")
-               (commit (string-append "v" version))))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
-          "0mp80bi2m56bb93szw87vy6q5s85yk9g91sl4pr51316rgdv5kkv"))))
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/editorconfig/editorconfig-vim")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0mp80bi2m56bb93szw87vy6q5s85yk9g91sl4pr51316rgdv5kkv"))))
     (build-system copy-build-system)
     (arguments
-     '(#:install-plan
-       '(("autoload" "share/vim/vimfiles/")
-         ("doc" "share/vim/vimfiles/")
-         ("plugin" "share/vim/vimfiles/"))))
-    (home-page "https://editorconfig.org/")
+     (list #:install-plan
+           #~'(("autoload" "share/vim/vimfiles/")
+               ("doc" "share/vim/vimfiles/")
+               ("plugin" "share/vim/vimfiles/"))))
+    (home-page "https://editorconfig.org")
     (synopsis "EditorConfig plugin for Vim")
-    (description "EditorConfig makes it easy to maintain the correct coding
-style when switching between different text editors and between different
-projects.  The EditorConfig project maintains a file format and plugins for
-various text editors which allow this file format to be read and used by those
-editors.")
+    (description
+     "This package provides a Vim plugin for automatically applying the
+preferences stated in a project's EditorConfig specification file.")
     (license license:bsd-2)))
 
+(define-public editorconfig-vim
+  (deprecated-package "editorconfig-vim" vim-editorconfig))
+
 (define-public neovim-syntastic
   (package
     (inherit vim-syntastic)