diff mbox series

[bug#57351] gnu: Add vpn-slice.

Message ID 20220823084447.11995-1-arunisaac@systemreboot.net
State Accepted
Headers show
Series [bug#57351] gnu: Add vpn-slice. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Arun Isaac Aug. 23, 2022, 8:44 a.m. UTC
* gnu/packages/vpn.scm (vpn-slice): New variable.
---
 gnu/packages/vpn.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Efraim Flashner Aug. 29, 2022, 1:35 p.m. UTC | #1
On Tue, Aug 23, 2022 at 02:14:47PM +0530, Arun Isaac wrote:
> * gnu/packages/vpn.scm (vpn-slice): New variable.
> ---
>  gnu/packages/vpn.scm | 28 ++++++++++++++++++++++++++++
>  1 file changed, 28 insertions(+)
> 
> diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
> index 1ec619b0c2..c68511e04b 100644
> --- a/gnu/packages/vpn.scm
> +++ b/gnu/packages/vpn.scm
> @@ -1197,3 +1197,31 @@ (define-public xl2tpd
>       "xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661).
>  L2TP allows you to tunnel PPP over UDP.")
>      (license license:gpl2)))
> +
> +(define-public vpn-slice
> +  (package
> +    (name "vpn-slice")
> +    (version "0.16.1")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "vpn-slice" version))
> +              (sha256
> +               (base32
> +                "1anfx4hn2ggm6sbwqmqx68s3l2rjcy4z4l038xqb440jnk8jvl18"))))
> +    (build-system python-build-system)
> +    (inputs (list python-dnspython python-setproctitle))
> +    (home-page "https://github.com/dlenski/vpn-slice")
> +    (synopsis "Split tunneling replacement for vpnc-script")
> +    (description "vpn-slice is a replacement for the vpnc-script used by
> +OpenConnect and vpnc.  Instead of trying to copy the behavior of standard
> +corporate VPN clients, which normally reroute all your network traffic through
> +the VPN, vpn-slice tries to minimize your contact with an intrusive VPN.  This
> +is also known as a split-tunnel VPN, since it splits your traffic between the
> +VPN tunnel and your normal network interfaces.
> +
> +By default, vpn-slice only routes traffic for specific hosts or subnets
> +through the VPN.  It automatically looks up named hosts, using the VPN's DNS
> +servers, and adds entries for them to your /etc/hosts (which it cleans up
> +after VPN disconnection), however it does not otherwise alter your
> +/etc/resolv.conf at all.")
> +    (license license:gpl3+)))

Are there any tests in the upstream repo?

I'd wrap some of the commands in @command{...} and the /etc files in
@file{...}.
Arun Isaac Aug. 29, 2022, 6:50 p.m. UTC | #2
> Are there any tests in the upstream repo?

No, there aren't any tests.

> I'd wrap some of the commands in @command{...} and the /etc files in
> @file{...}.

Done. An updated patch follows.
diff mbox series

Patch

diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 1ec619b0c2..c68511e04b 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -1197,3 +1197,31 @@  (define-public xl2tpd
      "xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661).
 L2TP allows you to tunnel PPP over UDP.")
     (license license:gpl2)))
+
+(define-public vpn-slice
+  (package
+    (name "vpn-slice")
+    (version "0.16.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "vpn-slice" version))
+              (sha256
+               (base32
+                "1anfx4hn2ggm6sbwqmqx68s3l2rjcy4z4l038xqb440jnk8jvl18"))))
+    (build-system python-build-system)
+    (inputs (list python-dnspython python-setproctitle))
+    (home-page "https://github.com/dlenski/vpn-slice")
+    (synopsis "Split tunneling replacement for vpnc-script")
+    (description "vpn-slice is a replacement for the vpnc-script used by
+OpenConnect and vpnc.  Instead of trying to copy the behavior of standard
+corporate VPN clients, which normally reroute all your network traffic through
+the VPN, vpn-slice tries to minimize your contact with an intrusive VPN.  This
+is also known as a split-tunnel VPN, since it splits your traffic between the
+VPN tunnel and your normal network interfaces.
+
+By default, vpn-slice only routes traffic for specific hosts or subnets
+through the VPN.  It automatically looks up named hosts, using the VPN's DNS
+servers, and adds entries for them to your /etc/hosts (which it cleans up
+after VPN disconnection), however it does not otherwise alter your
+/etc/resolv.conf at all.")
+    (license license:gpl3+)))