diff mbox series

[bug#57298,v2,2/5] gnu: Add ocaml-pprint.

Message ID 20220822095439.12522-2-pukkamustard@posteo.net
State Accepted
Headers show
Series [bug#57298,v2,1/5] gnu: Add ocaml-afl-persistent. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

pukkamustard Aug. 22, 2022, 9:54 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-pprint): New variable.
---
 gnu/packages/ocaml.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 14550d1232..aaa596ae20 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8579,6 +8579,31 @@  (define-public ocaml-afl-persistent
 repeated forking and is much faster.")
     (license license:expat)))
 
+(define-public ocaml-pprint
+  (package
+    (name "ocaml-pprint")
+    (version "20220103")
+    (home-page "https://github.com/fpottier/pprint")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "09y6nwnjldifm47406q1r9987njlk77g4ifqg6qs54dckhr64vax"))))
+    (build-system dune-build-system)
+    (synopsis "OCaml pretty-printing combinator library and rendering
+engine")
+    (description "This OCaml library offers a set of combinators for building
+so-called documents as well as an efficient engine for converting documents to
+a textual, fixed-width format.  The engine takes care of indentation and line
+breaks, while respecting the constraints imposed by the structure of the
+document and by the text width.")
+    (license license:lgpl2.0)))
+
 (define-public ocaml-bibtex2html
   (package
     (name "ocaml-bibtex2html")