diff mbox series

[bug#57335] gnu: Add r-polylabelr.

Message ID 20220822084244.28534-1-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#57335] gnu: Add r-polylabelr. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu Aug. 22, 2022, 8:42 a.m. UTC
* gnu/packages/cran.scm (r-polylabelr): New variable.
---
 gnu/packages/cran.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 706b3ef38b2f7ce9f05aa56e2eaaaf1c19e25f90

Comments

Ricardo Wurmus Aug. 22, 2022, 9:19 a.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> * gnu/packages/cran.scm (r-polylabelr): New variable.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e03b707162..35b7efb672 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1483,6 +1483,28 @@  (define-public r-polychrome
 colleagues (2019) @url{https://doi:10.18637/jss.v090.c01}.")
     (license license:asl2.0)))
 
+(define-public r-polylabelr
+  (package
+    (name "r-polylabelr")
+    (version "0.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "polylabelr" version))
+              (sha256
+               (base32
+                "01b2v0l5g8nxwbd6nwqv8ahypgh6gfhd4qabg75brlj7z1iyfzf2"))))
+    (properties `((upstream-name . "polylabelr")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-rcpp))
+    (home-page "https://github.com/jolars/polylabelr")
+    (synopsis "Finding pole of inaccessibility (visual center) of a polygon")
+    (description
+     "This package provides a wrapper around the @code{C++} library @code{
+polylabel} from @code{Mapbox}, providing an efficient routine for finding the
+approximate pole of inaccessibility of a polygon, which usually serves as an
+excellent candidate for labeling of a polygon.")
+    (license license:expat)))
+
 (define-public r-poorman
   (package
     (name "r-poorman")