diff mbox series

[bug#57333] gnu: zsh-autopair

Message ID 20220822042800.1564-1-me@gyara.moe
State Accepted
Headers show
Series [bug#57333] gnu: zsh-autopair | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

ギャラ Aug. 22, 2022, 4:28 a.m. UTC
---

This patch added zsh-autopair, a zsh plugin that auto-closes, deletes
and skips over matching delimiters in zsh intelligently to guix.

 gnu/packages/shellutils.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Ludovic Courtès Sept. 8, 2022, 12:40 p.m. UTC | #1
Hi,

gyara <me@gyara.moe> skribis:

> ---
>
> This patch added zsh-autopair, a zsh plugin that auto-closes, deletes
> and skips over matching delimiters in zsh intelligently to guix.

I tweaked the description¹ and commit log² and applied it.

Thanks!

Ludo’.

¹ https://guix.gnu.org/manual/devel/en/html_node/Synopses-and-Descriptions.html
² https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html
diff mbox series

Patch

diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 110cbe9fda..295bece21c 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -38,6 +38,7 @@  (define-module (gnu packages shellutils)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (guix build-system python)
@@ -145,6 +146,29 @@  (define-public boxes
 text.")
     (license license:gpl2)))
 
+(define-public zsh-autopair
+  (package
+    (name "zsh-autopair")
+    (version "1.0")
+    (home-page "https://github.com/hlissner/zsh-autopair")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/hlissner/zsh-autopair.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1h0vm2dgrmb8i2pvsgis3lshc5b0ad846836m62y8h3rdb3zmpy1"))))
+    (build-system copy-build-system)
+    (arguments
+     '(#:install-plan '(("autopair.zsh"
+                         "/share/zsh/plugins/zsh-autopair/zsh-autopair.zsh"))))
+    (synopsis "Auto-close and delete matching delimiters in zsh")
+    (description
+     "A simple plugin that auto-closes, deletes and skips over matching delimiters in zsh intelligently.")
+    (license license:expat)))
+
 (define-public zsh-autosuggestions
   (package
     (name "zsh-autosuggestions")