diff mbox series

[bug#57317,v2,2/2] gnu: package-management: Remove mentions of GUIX_EXTENSIONS_PATH.

Message ID 20220821154349.22575-2-paren@disroot.org
State Accepted
Headers show
Series [bug#57317,v2,1/2] build: profiles: Implicitly set GUIX_EXTENSIONS_PATH. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( Aug. 21, 2022, 3:43 p.m. UTC
* gnu/packages/package-management.scm (guix)[native-search-paths]:
  Remove GUIX_EXTENSIONS_PATH.
(guix-modules)[description]: Remove instructions to set
GUIX_EXTENSIONS_PATH.
---
 gnu/packages/package-management.scm | 16 ++--------------
 1 file changed, 2 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 0469c73ff5..ec133a15dd 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -477,10 +477,7 @@  (define code
          ("guile-lzlib" ,guile-lzlib)
          ("guile-zstd" ,guile-zstd)))
       (native-search-paths
-       (list (search-path-specification
-              (variable "GUIX_EXTENSIONS_PATH")
-              (files '("share/guix/extensions")))
-             ;; (guix git) and (guix build download) honor this variable whose
+       (list ;; (guix git) and (guix build download) honor this variable whose
              ;; name comes from OpenSSL.
              $SSL_CERT_DIR))
       (home-page "https://www.gnu.org/software/guix/")
@@ -726,16 +723,7 @@  (define-public guix-modules
 module} command.  The @command{guix module create} sub-command creates
 @dfn{environment modules}, allowing you to manipulate software environments
 with the @command{module} command commonly found on @acronym{HPC,
-high-performance computing} clusters.
-
-To use this extension, set the @env{GUIX_EXTENSIONS_PATH} environment
-variable, along these lines:
-
-@example
-export GUIX_EXTENSIONS_PATH=\"$HOME/.guix-profile/share/guix/extensions\"
-@end example
-
-Replace @code{$HOME/.guix-profile} with the appropriate profile.")
+high-performance computing} clusters.")
     (license license:gpl3+)))