diff mbox series

[bug#57312] gnu: Add elm-community-random-extra.

Message ID 20220820230557.23691-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#57312] gnu: Add elm-community-random-extra. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Aug. 20, 2022, 11:05 p.m. UTC
* gnu/packages/elm.scm (elm-community-random-extra): New variable.
---
 gnu/packages/elm.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Maxim Cournoyer Sept. 28, 2022, 6:31 p.m. UTC | #1
Hi!

jgart <jgart@dismail.de> writes:

> * gnu/packages/elm.scm (elm-community-random-extra): New variable.

I did the following changes:

--8<---------------cut here---------------start------------->8---
modified   gnu/packages/elm.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
 ;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -491,20 +492,17 @@ (define-public elm-community-random-extra
   (package
     (name "elm-community-random-extra")
     (version "3.2.0")
-    (source
-      (elm-package-origin 
-        "elm-community/random-extra"
-        version
-        (base32 "13l48mx4wj7qdxl1shn9ij34izap256vv3k49ncnxpkjb7m1m3xk")))
+    (source (elm-package-origin
+             "elm-community/random-extra" version
+             (base32 "13l48mx4wj7qdxl1shn9ij34izap256vv3k49ncnxpkjb7m1m3xk")))
     (build-system elm-build-system)
     (propagated-inputs (list elm-time elm-random elm-core))
     (inputs (list elm-explorations-test))
     (home-page
-"https://package.elm-lang.org/packages/elm-community/random-extra/3.2.0")
+     "https://package.elm-lang.org/packages/elm-community/random-extra/")
     (synopsis "Extra functions for the Elm core random library")
-    (description
-"@code{emacs-community-random-extra} includes lots of extra helper
-functions for the Random module.")
+    (description "@code{emacs-community-random-extra} includes lots of extra
+helper functions for the Random module.")
     (license license:bsd-3)))
--8<---------------cut here---------------end--------------->8---
 
And pushed!

Thank you,

Maxim
jgart Sept. 28, 2022, 8:37 p.m. UTC | #2
On Wed, 28 Sep 2022 14:31:03 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:

hi!

THNX!!!
diff mbox series

Patch

diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 74a43a4ff2..a85c8c5f42 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -487,6 +487,26 @@  (define-public elm-explorations-markdown
 on the @code{marked} project, which focuses on speed.")
     (license license:bsd-3)))
 
+(define-public elm-community-random-extra
+  (package
+    (name "elm-community-random-extra")
+    (version "3.2.0")
+    (source
+      (elm-package-origin 
+        "elm-community/random-extra"
+        version
+        (base32 "13l48mx4wj7qdxl1shn9ij34izap256vv3k49ncnxpkjb7m1m3xk")))
+    (build-system elm-build-system)
+    (propagated-inputs (list elm-time elm-random elm-core))
+    (inputs (list elm-explorations-test))
+    (home-page
+"https://package.elm-lang.org/packages/elm-community/random-extra/3.2.0")
+    (synopsis "Extra functions for the Elm core random library")
+    (description
+"@code{emacs-community-random-extra} includes lots of extra helper
+functions for the Random module.")
+    (license license:bsd-3)))
+
 (define-public elm-todomvc
   (let ((commit "f236e7e56941c7705aba6e42cb020ff515fe3290")
         (revision "1"))