diff mbox series

[bug#57308] gnu: Add adwaita-qt.

Message ID 20220820124556.32596-1-whatson@gmail.com
State New
Headers show
Series [bug#57308] gnu: Add adwaita-qt. | expand

Checks

Context Check Description
cbaines/applying patch fail
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Andrew Whatson Aug. 20, 2022, 12:45 p.m. UTC
* gnu/packages/qt.scm (adwait-qt): New variable.
---
 gnu/packages/qt.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

Steve George April 2, 2024, 10:56 a.m. UTC | #1
Hi Andrew,

You sent this patch in a while ago, I was just looking at it and adwaita-qt is no longer maintained according to their repository. Is there an alternative that you'd like to update your patch to, or should we close this?

Thanks,

Steve
Steve George April 2, 2024, 3:31 p.m. UTC | #2
Hi Andrew,

You sent this patch in a while ago, I was just looking at it and 
adwaita-qt is no longer maintained according to their repository. Is 
there an alternative that you'd like to update your patch to, or should 
we close this?

Thanks,

Steve
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 8814f7cfd8..20739eeae8 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -4060,3 +4060,39 @@  (define-public soqt
 also compatible with SGI and TGS Open Inventor, and the API is based on the API
 of the InventorXt GUI component toolkit.")
     (license license:bsd-3))))
+
+(define-public adwaita-qt
+  (package
+    (name "adwaita-qt")
+    (version "1.4.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/FedoraQt/adwaita-qt")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1i83mkvy2md88fl3fhzvhhz9bvqqg31m8qdrgc80ylhclzafznxp"))))
+    (build-system qt-build-system)
+    (arguments
+     (list
+      #:tests? #f                       ; no target
+      #:configure-flags #~(list
+                           (string-append "-DQT_PLUGINS_DIR="
+                                          #$output
+                                          "/lib/qt5/plugins"))))
+    (inputs
+     (list qtbase-5 qtx11extras))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "QT_PLUGIN_PATH")
+            (files '("lib/qt5/plugins")))))
+    (synopsis "Qt style to blend applications into GNOME Shell")
+    (description "A native style to blend Qt5/Qt6 applications to look like
+they belong into GNOME Shell.
+
+This style provides all four variants of GTK Adwaita theme:
+Adwaita, Adwaita-dark, HighContrast, HighContrastInverse")
+    (home-page "https://github.com/FedoraQt/adwaita-qt")
+    (license license:lgpl2.1)))