diff mbox series

[bug#57257,21/31] gnu: pcmanfm-qt: Update to 1.1.0.

Message ID 20220817032500.30011-21-iyzsong@envs.net
State Accepted
Headers show
Series Update LXQt to 1.1.0 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Deslauriers, Douglas via Guix-patches" via Aug. 17, 2022, 3:24 a.m. UTC
From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/lxqt.scm (pcmanfm-qt)
[version]: Update to 1.1.0.
[inputs]: Add lxqt-themes.
[arguments]: Remove patch-source phase.  Add patch-settings.conf.in phase.
---
 gnu/packages/lxqt.scm | 31 +++++++++++++++----------------
 1 file changed, 15 insertions(+), 16 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 08e33ca0e3..d2cbd1e131 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -843,32 +843,31 @@  (define-public libfm-qt
 (define-public pcmanfm-qt
   (package
     (name "pcmanfm-qt")
-    (version "0.17.0")
+    (version "1.1.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
                            version "/" name "-" version ".tar.xz"))
        (sha256
-        (base32 "1axs7dnh2z08ygy28iipfbgfck15k2i2pwlf0v8d8axjrmavzb3l"))))
+        (base32 "0pwl2j5kbs86vmq86phavq89bl2i82ic839bjk0v8kmxm9q2mrh9"))))
     (build-system cmake-build-system)
+    (arguments
+     (list
+      #:tests? #f                       ; no tests
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'configure 'patch-settings.conf.in
+            (lambda* (#:key inputs #:allow-other-keys)
+              (let ((wallpaper (search-input-file inputs
+                                "share/lxqt/wallpapers/waves-logo.png")))
+               (substitute* "config/pcmanfm-qt/lxqt/settings.conf.in"
+                 (("Wallpaper=.*")
+                  (string-append "Wallpaper=" wallpaper "\n")))))))))
     (inputs
-     (list libfm-qt qtbase-5 qtx11extras))
+     (list libfm-qt qtbase-5 qtx11extras lxqt-themes))
     (native-inputs
      (list pkg-config qttools-5 lxqt-build-tools))
-    (arguments
-     '(#:tests? #f                      ; no tests
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-source
-           (lambda _
-             (substitute* '("autostart/CMakeLists.txt")
-               (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
-                "DESTINATION \"etc/xdg"))
-             (substitute* '("config/pcmanfm-qt/lxqt/settings.conf.in")
-               (("@LXQT_SHARE_DIR@")
-                "/run/current-system/profile/share/lxqt" ))
-             #t)))))
     (home-page "https://lxqt-project.org")
     (synopsis "File manager and desktop icon manager")
     (description "PCManFM-Qt is the Qt port of PCManFM, the file manager of