diff mbox series

[bug#57253,2/2] gnu: Add keychain.

Message ID 20220817000332.13801-1-GNUtoo@cyberdimension.org
State Accepted
Headers show
Series [bug#57253,1/2] gnu: greybird-gtk-theme: Build with librsvg-for-system. | expand

Commit Message

Denis 'GNUtoo' Carikli Aug. 17, 2022, 12:03 a.m. UTC
* gnu/packages/crypto.scm (keychain): New variable.
---
 gnu/packages/crypto.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

Comments

Björn Höfling Sept. 21, 2022, 4:14 p.m. UTC | #1
Hi Denis,
Hi iyzsong,

On Wed, 17 Aug 2022 02:03:32 +0200
Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> wrote:

> * gnu/packages/crypto.scm (keychain): New variable.
> ---
>  gnu/packages/crypto.scm | 41
> +++++++++++++++++++++++++++++++++++++++++ 1 file changed, 41
> insertions(+)
> 
[..]
> +
> +(define-public keychain

In commit 3220edac2a5ac816328bd65489513ae8d33fbe23, you pushed the
first patch, but you missed this here, and the patchset is still open.

I cannot find any discussions about this.

Did you just miss pushing "keychain" patch, or was there a specific
reason why you hold it back?

Thanks,

Björn
Denis 'GNUtoo' Carikli Sept. 21, 2022, 9:52 p.m. UTC | #2
On Wed, 21 Sep 2022 18:14:13 +0200
Björn Höfling <bjoern.hoefling@bjoernhoefling.de> wrote:

> Hi Denis,
> Hi iyzsong,
Hi,

> In commit 3220edac2a5ac816328bd65489513ae8d33fbe23, you pushed the
> first patch, but you missed this here, and the patchset is still open.
> 
> I cannot find any discussions about this.
> 
> Did you just miss pushing "keychain" patch, or was there a specific
> reason why you hold it back?
I think that someone needs to review it and to push it if it's OK.

The reason might be related to the fact that I sent two unrelated
patches in the same serie (I'm unsure how best to send unrelated
patches).

Denis.
diff mbox series

Patch

diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 9dcffd8dd4..3553415ad5 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -24,6 +24,7 @@ 
 ;;; Copyright © 2021, 2022 Brendan Tildesley <mail@brendan.scot>
 ;;; Copyright © 2022 Allan Adair <allan@adair.no>
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -46,6 +47,7 @@  (define-module (gnu packages crypto)
   #:use-module (gnu packages aidc)
   #:use-module (gnu packages attr)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
@@ -1699,3 +1701,42 @@  (define-public libxcrypt
 descrypt.")
     (home-page "https://github.com/besser82/libxcrypt")
     (license license:lgpl2.1)))
+
+(define-public keychain
+  (package
+    (name "keychain")
+    (version "2.8.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/funtoo/keychain")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1bkjlg0a2bbdjhwp37ci1rwikvrl4s3xlbf2jq2z4azc96dr83mj"))))
+    (build-system gnu-build-system)
+    (native-inputs (list bash))
+    (arguments
+     `(#:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (delete 'configure)
+                  (replace 'install
+                    (lambda _
+                      (install-file "keychain"
+                                    (string-append %output "/bin/"))
+                      (install-file "keychain.1"
+                                    (string-append %output "/share/man/man1"))
+                      #t)))))
+    (synopsis
+     "SSH or GPG agent frontend that can share a single agent on the same
+system")
+    (description
+     "Keychain is usually run from shell profiles like ~/.bash_profile, but
+it is also possible to use it with non-interactive shells.  It works
+with various operating systems (including GNU/Linux and HURD) and
+shells (like bourne-compatible, csh-compatible and fish shells).  By
+default Keychain will only start ssh-agent, but it can also be
+configured to start gpg-agent.")
+    (home-page "https://www.funtoo.org/Keychain")
+    (license license:gpl2)))