diff mbox series

[bug#57221] gnu: Add python-nanoid.

Message ID 20220815020553.29149-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#57221] gnu: Add python-nanoid. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Aug. 15, 2022, 2:05 a.m. UTC
* gnu/packages/python-xyz.scm (python-nanoid): New variable.
---
 gnu/packages/python-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

宋文武 Aug. 15, 2022, 5:43 a.m. UTC | #1
jgart <jgart@dismail.de> writes:

> * gnu/packages/python-xyz.scm (python-nanoid): New variable.
> ---
>  gnu/packages/python-xyz.scm | 33 +++++++++++++++++++++++++++++++++
>  1 file changed, 33 insertions(+)

I fixed 'description' (indent and ending period) and pushed, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 13ab2f2c8b..2122db30c6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30531,6 +30531,39 @@  (define-public python-types-orjson
 etc. to check code that uses @code{orjson}.")
     (license license:asl2.0)))
 
+(define-public python-nanoid
+  ;; There are no tests on PyPi.
+  (let ((commit "061f9a598f310b0e2e91b9ed6ce725a22770da64")
+        (revision "0"))
+  (package
+    (name "python-nanoid")
+    (version "2.0.0")
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/puyuan/py-nanoid")
+           (commit commit)))
+         (file-name (git-file-name name commit))
+         (sha256
+          (base32 "0y1bcw0h27g8rkqq7cp33ywn0i0lp0q3rjixzkh4191y1dp9yf8s"))))
+    (build-system python-build-system)
+    (native-inputs (list python-pytest))
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+             (when tests?
+               (invoke "pytest")))))))
+    (home-page "https://github.com/puyuan/py-nanoid")
+    (synopsis "Unique string ID generator")
+    (description
+"This package provides a tiny, secure, URL-friendly, unique string ID
+generator for Python")
+    (license license:expat))))
+
 (define-public python-misskey
   (package
     (name "python-misskey")