diff mbox series

[bug#57056,v3,1/3] gnu: Add python-whatthepatch.

Message ID 20220814163600.28011-1-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#57056,v3,1/3] gnu: Add python-whatthepatch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Aug. 14, 2022, 4:35 p.m. UTC
* gnu/packages/python-web.scm (python-whatthepatch): New variable.
---
 gnu/packages/python-web.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 896e60aba2..0f00a23747 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7761,3 +7761,20 @@  (define-public python-shopifyapi
 ruby Shopify API gem.  The library makes HTTP requests to Shopify in order to
 list, create, update, or delete resources (e.g. Order, Product, Collection).")
     (license license:expat)))
+
+(define-public python-whatthepatch
+  (package
+    (name "python-whatthepatch")
+    (version "1.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "whatthepatch" version))
+              (sha256
+               (base32
+                "17zspm5sxhvggkdhwq4s0fzf4mkc825xshn734g2j2iy2xcylh65"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/cscorley/whatthepatch")
+    (synopsis "Patch parsing and application")
+    (description
+     "This package provides a library to parse and apply patches.")
+    (license license:expat)))