diff mbox series

[bug#57209,2/2] gnu: Add emacs-citar-org-roam.

Message ID 20220814160702.20435-2-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#57209,1/2] gnu: emacs-citar: Update to 1.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Aug. 14, 2022, 4:07 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-citar-org-roam): New variable.
---
 gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Nicolas Graves Aug. 15, 2022, 8:27 a.m. UTC | #1
Only the second patch is useful now that Nicolas Goaziou has updated
emacs-citar.
Andrew Tropin Aug. 22, 2022, 7:43 a.m. UTC | #2
On 2022-08-14 18:07, Nicolas Graves via Guix-patches via wrote:

> * gnu/packages/emacs-xyz.scm (emacs-citar-org-roam): New variable.
> ---
>  gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
>  1 file changed, 30 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index d80c8116b7..4fad5b1270 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -18980,6 +18980,36 @@ (define-public emacs-citar
>  citations.")
>      (license license:gpl3+)))
>  
> +(define-public emacs-citar-org-roam
> +  (package
> +    (name "emacs-citar-org-roam")
> +    (version "0.3")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/emacs-citar/citar-org-roam")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "1ldfs7g7ixnrwj23draiph4vy6xq7qgw18vhi7vbw6wvkh9fcv9r"))))
> +    (build-system emacs-build-system)
> +    (propagated-inputs (list emacs-org-roam emacs-citar))
> +    (home-page "https://github.com/emacs-citar/citar-org-roam")
> +    (synopsis "An Emacs pacakge to provide tighter Citar and Org-Roam integration")
> +    (description "\
> +Out-of-box, Citar provides default support for file-per-note bibliographic
> +notes that are compatible with Org-Roam v2. This package integrates directly
> +with the Org-Roam database, and provides the following additional features to
> +Citar note support:
> +@itemize
> +@item multiple references per note
> +@item multiple reference notes per file
> +@item ability to query note citations by reference
> +@item “live” updating of Citar UI for presence of notes
> +@end itemize")
> +    (license license:gpl3)))
> +
>  (define-public emacs-helm-bibtex
>    (let ((commit "aa775340ba691d2322948bfdc6a88158568a1399")
>          (revision "3"))

Removed article in synopsis and added doublespaces between sentences,
changed quotes to latex quotes in description, pushed as
114c9ea22fb3f8de466cebdfda133db735d4481e, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d80c8116b7..4fad5b1270 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18980,6 +18980,36 @@  (define-public emacs-citar
 citations.")
     (license license:gpl3+)))
 
+(define-public emacs-citar-org-roam
+  (package
+    (name "emacs-citar-org-roam")
+    (version "0.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/emacs-citar/citar-org-roam")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1ldfs7g7ixnrwj23draiph4vy6xq7qgw18vhi7vbw6wvkh9fcv9r"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-org-roam emacs-citar))
+    (home-page "https://github.com/emacs-citar/citar-org-roam")
+    (synopsis "An Emacs pacakge to provide tighter Citar and Org-Roam integration")
+    (description "\
+Out-of-box, Citar provides default support for file-per-note bibliographic
+notes that are compatible with Org-Roam v2. This package integrates directly
+with the Org-Roam database, and provides the following additional features to
+Citar note support:
+@itemize
+@item multiple references per note
+@item multiple reference notes per file
+@item ability to query note citations by reference
+@item “live” updating of Citar UI for presence of notes
+@end itemize")
+    (license license:gpl3)))
+
 (define-public emacs-helm-bibtex
   (let ((commit "aa775340ba691d2322948bfdc6a88158568a1399")
         (revision "3"))