@@ -17,6 +17,7 @@
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2022 Jacob Hrbek <kreyren@rixotstudio.cz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -261,7 +262,7 @@ (define libva-without-mesa
(define-public mesa
(package
(name "mesa")
- (version "21.3.8")
+ (version "22.1.3")
(source
(origin
(method url-fetch)
@@ -273,12 +274,11 @@ (define-public mesa
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "19wx5plk6z0hhi0zdzxjx8ynl3lhlc5mbd8vhwqyk92kvhxjf3g7"))
- (patches
- (search-patches "mesa-skip-tests.patch"))))
+ "1qwky31vdqh3y6i0mxqnrbq7jc39kjcyndpv4mbzz8d2gax353xr"))))
(build-system meson-build-system)
(propagated-inputs
- (list ;; The following are in the Requires.private field of gl.pc.
+ (list ;; The following are in the Requires.private field of gl.pc.
+ ;; NOTE(Krey): Since version 22.1.3 it requires libdrm_amdgpu[>=2.4.110]
libdrm
libvdpau
libx11
@@ -295,6 +295,7 @@ (define-public mesa
libxrandr
libxvmc
wayland
+ ;; NOTE(Krey): Since 22.1.3 requires wayland-protocols[>=1.24]
wayland-protocols)
;; TODO: Resort alphabetically.
;; Note: update the 'clang' input of mesa-opencl when bumping this.
@@ -355,17 +356,7 @@ (define-public mesa
"-Dvulkan-layers=device-select,overlay"
;; Also enable the tests.
- "-Dbuild-tests=true"
-
- ;; on non-intel systems, drop i915 and i965
- ;; from the default dri drivers
- ,@(match (%current-system)
- ((or "x86_64-linux" "i686-linux")
- '("-Ddri-drivers=i915,i965,nouveau,r200,r100"))
- (_
- '("-Ddri-drivers=nouveau,r200,r100")))
-
- "-Dllvm=enabled") ; default is x86/x86_64 only
+ "-Dbuild-tests=true")
;; XXX: 'debugoptimized' causes LTO link failures on some drivers. The
;; documentation recommends using 'release' for performance anyway.
Signed-off-by: Jacob Hrbek <kreyren@rixotstudio.cz> --- gnu/packages/gl.scm | 23 +++++++---------------- 1 file changed, 7 insertions(+), 16 deletions(-) -- 2.37.1