diff mbox series

[bug#57203] gnu: Add emacs-tamil99.

Message ID 20220814131020.21640-1-arunisaac@systemreboot.net
State Accepted
Headers show
Series [bug#57203] gnu: Add emacs-tamil99. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Arun Isaac Aug. 14, 2022, 1:10 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-tamil99): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 +++++++++++++++++++++-
 1 file changed, 21 insertions(+), 1 deletion(-)

Comments

Nicolas Goaziou Aug. 27, 2022, 8:29 a.m. UTC | #1
Hello,

Arun Isaac <arunisaac@systemreboot.net> writes:

> * gnu/packages/emacs-xyz.scm (emacs-tamil99): New variable.

I updated the package to latest 0.1.1 release and applied your patch.
Thank you.

> +    (description "@code{emacs-tamil99} implements the tamil99 input method for
> +Emacs.  tamil99 is an input method for the Tamil script.")

I also expounded a bit the description.

Regards,
Arun Isaac Aug. 28, 2022, 11:07 a.m. UTC | #2
Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3c1d322db3..1ca02a838d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16,7 +16,7 @@ 
 ;;; Copyright © 2016, 2019 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2016-2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016–2022 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
 ;;; Copyright © 2017, 2018, 2019, 2020, 2022 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017, 2018, 2019, 2020, 2021, 2022 Clément Lassieur <clement@lassieur.org>
@@ -31967,3 +31967,23 @@  (define-public emacs-vundo
 tree to go back to previous buffer states.  To use vundo, type @kbd{M-x vundo RET} in
 the buffer you want to undo.  An undo tree buffer should pop up.")
     (license license:gpl3+)))
+
+(define-public emacs-tamil99
+  (package
+    (name "emacs-tamil99")
+    (version "0.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.systemreboot.net/tamil99/")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1cr903sgma9qi3hkk4snn5zza69c3szljhc984s1yl7p51a0x7mk"))))
+    (build-system emacs-build-system)
+    (home-page "https://git.systemreboot.net/tamil99/about/")
+    (synopsis "Tamil99 input method for Emacs")
+    (description "@code{emacs-tamil99} implements the tamil99 input method for
+Emacs.  tamil99 is an input method for the Tamil script.")
+    (license license:gpl3+)))