diff mbox series

[bug#56908,v3] gnu: Add gopls.

Message ID 20220814124126.14868-1-paren@disroot.org
State Accepted
Headers show
Series [bug#56908,v3] gnu: Add gopls. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( Aug. 14, 2022, 12:41 p.m. UTC
* gnu/packages/golang.scm (gopls): New variable.
---
 gnu/packages/golang.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)

Comments

\( Aug. 14, 2022, 1:52 p.m. UTC | #1
Uh, please ignore this patch. I think it may be missing lots of
dependencies. I'll send a v4 with the missing deps when I have
time.

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1ce55875d8..1ade3b81b2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2560,6 +2560,22 @@  (define-public go-golang-org-x-tools
       (home-page "https://go.googlesource.com/tools/")
       (license license:bsd-3))))
 
+(define-public gopls
+  (package
+    (inherit go-golang-org-x-tools)
+    (name "gopls")
+    (arguments
+     (list #:unpack-path "golang.org/x/tools"
+           #:import-path "golang.org/x/tools/gopls"
+           #:install-source? #f))
+    (inputs (list go-golang-org-x-sync))
+    (synopsis "Go language server implementation")
+    (description
+     "This package provides the @acronym{LSP, Language Server Protocol}
+server implementation for the Go programming language.  It provides
+on-the-fly code linting, formatting, completion, and introspection for
+Go code in text editors supporting LSP.")))
+
 (define-public go-golang-org-x-crypto
   (let ((commit "2aa609cf4a9d7d1126360de73b55b6002f9e052a")
         (revision "5"))