diff mbox series

[bug#57173] gnu: yt-dlp: Update to 2022.08.08.

Message ID 20220813135301.22574-1-raingloom@riseup.net
State Accepted
Headers show
Series [bug#57173] gnu: yt-dlp: Update to 2022.08.08. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Csepp Aug. 13, 2022, 1:53 p.m. UTC
* gnu/packages/video.scm (yt-dlp): Update to 2022.08.08.
  [source]: remove snippet, switch to git-fetch
---
 gnu/packages/video.scm | 23 ++++++-----------------
 1 file changed, 6 insertions(+), 17 deletions(-)

Comments

Tobias Geerinckx-Rice Aug. 13, 2022, 2:19 p.m. UTC | #1
Hi raingloom,

raingloom 写道:
> * gnu/packages/video.scm (yt-dlp): Update to 2022.08.08.

Thanks!

Since yt-dlp was already up to date, I've turned this into a 
‘fetch from git’ patch with the following additions:

>   [source]: remove snippet, switch to git-fetch

  ^^ extraneous indentation; s/remove/Remove/.

When using GIT-FETCH, always set the file-name to something 
meaningful:

  (file-name (git-file-name name version))

> -                   ;; Delete the pre-generated files, except 
> for the man page
> -                   ;; which requires 'pandoc' to build.

OK, but then we do need to build it ourselves, not remove it.

Done in c2481b1bea56f2885110d5af0a6cff36a3d95933.

The new package works fine, but differs slightly: 
extractor/lazy_extractors.py is no longer installed.  What's up 
with that?

Leaving open for now,

T G-R
Csepp Aug. 14, 2022, 12:42 p.m. UTC | #2
Tobias Geerinckx-Rice <me@tobias.gr> writes:

> [[PGP Signed Part:Undecided]]
> Hi raingloom,
>
> raingloom 写道:
>> * gnu/packages/video.scm (yt-dlp): Update to 2022.08.08.
>
> Thanks!
>
> Since yt-dlp was already up to date, I've turned this into a ‘fetch
> from git’ patch with the following additions:
>
>>   [source]: remove snippet, switch to git-fetch
>
>  ^^ extraneous indentation; s/remove/Remove/.

Dang, I'll get the hang of the changelog format sometime this decade. :)

> When using GIT-FETCH, always set the file-name to something
> meaningful:
>
>  (file-name (git-file-name name version))
>
>> -                   ;; Delete the pre-generated files, except for
>> the man page
>> -                   ;; which requires 'pandoc' to build.
>
> OK, but then we do need to build it ourselves, not remove it.
>
> Done in c2481b1bea56f2885110d5af0a6cff36a3d95933.

I lazily assumed it was being generated already, I guess the comment was
misleading and I should have verified it.

> The new package works fine, but differs slightly:
> extractor/lazy_extractors.py is no longer installed.  What's up with
> that?

Not sure what that is or where it's used.  I'll try to take a look soon-ish.

> Leaving open for now,
>
> T G-R
>
> [[End of PGP Signed Part]]
Björn Höfling Sept. 21, 2022, 9:20 a.m. UTC | #3
On Sat, 13 Aug 2022 16:19:46 +0200
Tobias Geerinckx-Rice via Guix-patches via <guix-patches@gnu.org> wrote:

> Leaving open for now,

Hi raingloom, hi Tobias,

is there anything left here? Will you provide an updated patch with
some remainings, or can we close this here?

I'm just skimming through older patches and try to identify what needs
to be pushed vs can be closed.

Thanks,

Björn
Vagrant Cascadian Sept. 2, 2023, 3:58 a.m. UTC | #4
On 2022-08-14, Csepp wrote:
> Tobias Geerinckx-Rice <me@tobias.gr> writes:
>> raingloom 写道:
>>> * gnu/packages/video.scm (yt-dlp): Update to 2022.08.08.
...
>> When using GIT-FETCH, always set the file-name to something
>> meaningful:
>>
>>  (file-name (git-file-name name version))
>>
>>> -                   ;; Delete the pre-generated files, except for
>>> the man page
>>> -                   ;; which requires 'pandoc' to build.
>>
>> OK, but then we do need to build it ourselves, not remove it.
>>
>> Done in c2481b1bea56f2885110d5af0a6cff36a3d95933.
>
> I lazily assumed it was being generated already, I guess the comment was
> misleading and I should have verified it.
>
>> The new package works fine, but differs slightly:
>> extractor/lazy_extractors.py is no longer installed.  What's up with
>> that?
>
> Not sure what that is or where it's used.  I'll try to take a look soon-ish.
>
>> Leaving open for now,

If there are other outstanding issues, might be best to open a new bug
for them at this point?

yt-dlp has been updated several times since, the latest being:

88d107b2b9bf72a628065a1475ecce7b49852c35 gnu: yt-dlp: Update to 2023.07.06.

Marking as done.

live well,
  vagrant
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6d0b5ccb58..94ef3f0468 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2486,26 +2486,15 @@  (define-public youtube-dl
 (define-public yt-dlp
   (package/inherit youtube-dl
     (name "yt-dlp")
-    (version "2022.07.18")
+    (version "2022.08.08")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/yt-dlp/yt-dlp/"
-                                  "releases/download/"
-                                  version "/yt-dlp.tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/yt-dlp/yt-dlp/")
+                    (commit version)))
               (sha256
                (base32
-                "1wmzfqhysx1mqdba4ikvm6nbahasihi4xgqwqad20y3vs701slyj"))
-              (snippet
-               #~(begin
-                   ;; Delete the pre-generated files, except for the man page
-                   ;; which requires 'pandoc' to build.
-                   (for-each delete-file
-                             (list "yt-dlp"
-                                   ;;pandoc is needed to generate
-                                   ;;"yt-dlp.1"
-                                   "completions/bash/yt-dlp"
-                                   "completions/fish/yt-dlp.fish"
-                                   "completions/zsh/_yt-dlp"))))))
+                "07qz1zdndlpki0asw35zk5hdjcwpl3n1g54nxg4yb1iykbyv7rll"))))
     (arguments
      (substitute-keyword-arguments (package-arguments youtube-dl)
        ((#:tests? _) #t)