diff mbox series

[bug#50796] gnu: Add pn.

Message ID 20220811191105.958967-1-antero@mailbox.org
State Accepted
Headers show
Series [bug#50796] gnu: Add pn. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Antero Mejr Aug. 11, 2022, 7:11 p.m. UTC
* gnu/packages/messaging.scm (pn): New variable.
---
Updated with new gexps and retested.

gnu/packages/messaging.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Efraim Flashner Aug. 12, 2022, 2:39 p.m. UTC | #1
I pushed the patch with a few changes.

On Thu, Aug 11, 2022 at 03:11:05PM -0400, Antero Mejr via Guix-patches via wrote:
> * gnu/packages/messaging.scm (pn): New variable.
> ---
> Updated with new gexps and retested.
> 
> gnu/packages/messaging.scm | 31 +++++++++++++++++++++++++++++++
>  1 file changed, 31 insertions(+)
> 
> diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
> index 47798c3586..704feb1177 100644
> --- a/gnu/packages/messaging.scm
> +++ b/gnu/packages/messaging.scm
> @@ -3446,4 +3446,35 @@ (define-public python-harmony
>      (home-page "https://github.com/taylordotfish/harmony")
>      (license license:gpl3+)))
>  
> +(define-public pn
> +  (package
> +    (name "pn")
> +    (version "0.9.0")
> +    (home-page "https://github.com/Orange-OpenSource/pn")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url home-page)
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "1lvzb0yixj7wmmqzsri20k9nn3gf06j0yjvmg2mi1zihywq7s4dx"))))
> +    (build-system cmake-build-system)
> +    (arguments
> +     (list #:tests? #f ;no tests
> +           #:phases #~(modify-phases %standard-phases
> +                        (add-after 'unpack 'sub-bin-path
> +                          (lambda _
> +                            (substitute* "CMakeLists.txt"
> +                              (("DESTINATION \\$\\{AWKLIBPATH\\}")
> +                               "DESTINATION bin")))))))

I changed the DESTINATION so that the library would install to
#$output/lib.

> +    (inputs (list libphonenumber icu4c protobuf))

I re-sorted the inputs alphabetically.

> +    (synopsis "Command-line validation tool for phone numbers")
> +    (description
> +     "@code{pn} provides a command line tool that allows users to operate on
> +phone numbers (get validity information, reformat them, or extract numbers from
> +a text snippet), using @code{libphonenumber}.")
> +    (license license:asl2.0)))
> +
>  ;;; messaging.scm ends here
> -- 
> 2.37.1
> 
> 
> 
>
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 47798c3586..704feb1177 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3446,4 +3446,35 @@  (define-public python-harmony
     (home-page "https://github.com/taylordotfish/harmony")
     (license license:gpl3+)))
 
+(define-public pn
+  (package
+    (name "pn")
+    (version "0.9.0")
+    (home-page "https://github.com/Orange-OpenSource/pn")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1lvzb0yixj7wmmqzsri20k9nn3gf06j0yjvmg2mi1zihywq7s4dx"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:tests? #f ;no tests
+           #:phases #~(modify-phases %standard-phases
+                        (add-after 'unpack 'sub-bin-path
+                          (lambda _
+                            (substitute* "CMakeLists.txt"
+                              (("DESTINATION \\$\\{AWKLIBPATH\\}")
+                               "DESTINATION bin")))))))
+    (inputs (list libphonenumber icu4c protobuf))
+    (synopsis "Command-line validation tool for phone numbers")
+    (description
+     "@code{pn} provides a command line tool that allows users to operate on
+phone numbers (get validity information, reformat them, or extract numbers from
+a text snippet), using @code{libphonenumber}.")
+    (license license:asl2.0)))
+
 ;;; messaging.scm ends here