diff mbox series

[bug#57106] gnu: wpa-supplicant-gui: Fix build.

Message ID 20220810094833.26717-1-timotej.lazar@araneo.si
State Accepted
Headers show
Series [bug#57106] gnu: wpa-supplicant-gui: Fix build. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Timotej Lazar Aug. 10, 2022, 9:48 a.m. UTC
* gnu/packages/admin.scm (wpa-supplicant-gui)[build-system]: Use
qt-build-system.
[phases]: Use G-exps. Drop trailing #t. Don’t wrap-program as that is done by
the build system.
---
 gnu/packages/admin.scm | 45 +++++++++++++++++-------------------------
 1 file changed, 18 insertions(+), 27 deletions(-)

Comments

Mathieu Othacehe Aug. 11, 2022, 8:57 a.m. UTC | #1
>  gnu/packages/admin.scm | 45 +++++++++++++++++-------------------------
>  1 file changed, 18 insertions(+), 27 deletions(-)

Looks nice! There are quite a few errors during the build-icons phase though:

--8<---------------cut here---------------start------------->8---
** (process:174): WARNING **: 08:55:01.036: Unable to create profile directory (Permission denied) (13)
Unable to init server: Could not connect: Connection refused
** Message: 08:55:01.044: Cannot create profile directory /homeless-shelter/.config/inkscape.
** Message: 08:55:01.044: Inkscape will run with default settings, and new settings will not be saved. 

** (inkscape:174): WARNING **: 08:55:01.109: Could not create directory '/homeless-shelter/.config/inkscape'

** (inkscape:174): WARNING **: 08:55:01.109: Could not create extension error log file '/homeless-shelter/.config/inkscape/extension-errors.log'
Fontconfig error: No writable cache directories
Fontconfig error: No writable cache directories
Fontconfig error: No writable cache directories
Fontconfig error: No writable cache directories
--8<---------------cut here---------------end--------------->8---

We can maybe get rid of them by starting a xorg-server and defining the HOME
variable? Could you please have a look?

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 146423d068..3aa65824c8 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -77,6 +77,7 @@  (define-module (gnu packages admin)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system perl)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system qt)
   #:use-module (guix build-system ruby)
   #:use-module (guix build-system trivial)
   #:use-module (guix download)
@@ -2145,34 +2146,24 @@  (define-public wpa-supplicant-gui
      ;; For icons.
      (modify-inputs (package-native-inputs wpa-supplicant)
        (prepend imagemagick inkscape/stable)))
+    (build-system qt-build-system)
     (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'chdir
-                    (lambda _
-                      (chdir "wpa_supplicant/wpa_gui-qt4")
-                      #t))
-                  (delete 'configure)
-                  (replace 'build
-                    (lambda _
-                      (invoke "qmake" "wpa_gui.pro")
-                      (invoke "make" "-j" (number->string (parallel-job-count)))
-                      (invoke "make" "-C" "icons")))
-                  (replace 'install
-                    (lambda* (#:key inputs outputs #:allow-other-keys)
-                      (let ((out (assoc-ref outputs "out"))
-                            (qt '("qtbase" "qtsvg-5")))
-                        (install-file "wpa_gui" (string-append out "/bin"))
-                        (install-file "wpa_gui.desktop"
-                                      (string-append out "/share/applications"))
-                        (copy-recursively "icons/hicolor"
-                                          (string-append out "/share/icons/hicolor"))
-                        (wrap-program (string-append out "/bin/wpa_gui")
-                          `("QT_PLUGIN_PATH" ":" prefix
-                            ,(map (lambda (label)
-                                    (string-append (assoc-ref inputs label)
-                                                   "/lib/qt5/plugins/"))
-                                  qt)))
-                        #t))))))
+     (list #:test-target "check"
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'chdir
+                 (lambda _ (chdir "wpa_supplicant/wpa_gui-qt4")))
+               (replace 'configure
+                 (lambda _ (invoke "qmake" "wpa_gui.pro")))
+               (add-after 'build 'build-icons
+                 (lambda _ (invoke "make" "-C" "icons")))
+               (replace 'install
+                 (lambda _
+                   (install-file "wpa_gui" (string-append #$output "/bin"))
+                   (install-file "wpa_gui.desktop"
+                                 (string-append #$output "/share/applications"))
+                   (copy-recursively "icons/hicolor"
+                                     (string-append #$output "/share/icons/hicolor")))))))
     (synopsis "Graphical user interface for WPA supplicant")))
 
 (define-public hostapd