diff mbox series

[bug#57062] gnu: kdeclarative: Fix build.

Message ID 20220808233308.12491-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#57062] gnu: kdeclarative: Fix build. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder Aug. 8, 2022, 11:33 p.m. UTC
For some reasons check phase fails w/o libxinerama.

* gnu/packages/kde-frameworks.scm (kdeclarative)[native-inputs]:
Add libxinerama.
---
 gnu/packages/kde-frameworks.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

宋文武 Aug. 9, 2022, 1:07 a.m. UTC | #1
Michael Rohleder <mike@rohleder.de> writes:

> For some reasons check phase fails w/o libxinerama.

Hello, I get the build pass without libxinerama, maybe other issue?
Michael Rohleder Aug. 9, 2022, 2:28 a.m. UTC | #2
Hi,

宋文武 <iyzsong@envs.net> writes:
> Hello, I get the build pass without libxinerama, maybe other issue?

Yes, I'm sorry!
-> close.
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 391db94f3a..76e16e0ae6 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2021 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2272,7 +2273,7 @@  (define-public kdeclarative
     (propagated-inputs
      (list kconfig kpackage))
     (native-inputs
-     (list extra-cmake-modules pkg-config xorg-server-for-tests))
+     (list extra-cmake-modules libxinerama pkg-config xorg-server-for-tests))
     (inputs
      (list kauth
            kbookmarks