diff mbox series

[bug#57056,3/3] gnu: python-lsp-server: Update to 1.5.0.

Message ID 20220808103608.23372-3-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#57056,1/3] gnu: Add python-whatthepatch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Aug. 8, 2022, 10:36 a.m. UTC
* gnu/packages/python-xyz.scm (python-lsp-server): Update to 1.5.0.
---
 gnu/packages/python-xyz.scm | 19 ++++---------------
 1 file changed, 4 insertions(+), 15 deletions(-)

Comments

Mathieu Othacehe Aug. 12, 2022, 9:03 a.m. UTC | #1
Hello,

> -       (modify-phases %standard-phases
> -         (add-before 'check 'set-HOME
> -           (lambda _ (setenv "HOME" "/tmp")))

You need to document it in the commit message, this way:

[arguments]{set-HOME}: Remove this phase because...
{check}: Do not replace it as test_pyqt_completion is not longer
failing.

or something similar.
>      (propagated-inputs
>       (list python-autopep8
>             python-pydocstyle
>             python-flake8
> -           python-future
>             python-jedi
>             python-lsp-jsonrpc
>             python-pluggy
>             python-pycodestyle
>             python-pyflakes
>             python-rope
> +           python-setuptools
>             python-ujson
>             python-yapf))
>      (native-inputs
>       (list python-coverage
>             python-flaky
>             python-matplotlib
> -           python-mock
>             python-numpy
>             python-pandas
>             python-pylint
>             python-pytest
>             python-pytest-cov
> -           python-versioneer))
> +           python-whatthepatch))

Ditto, with something like

[propagated-inputs]: Remove python-future and add python-setuptools.
[native-inputs]: Remove python-mock, python-versioneer and add
python-whatthepatch.

Could you please send a v2?

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9736930f15..a6f07d9252 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5258,49 +5258,38 @@  (define-public python-pydocstyle
 (define-public python-lsp-server
   (package
     (name "python-lsp-server")
-    (version "1.3.3")
+    (version "1.5.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "python-lsp-server" version))
        (sha256
         (base32
-         "0h6wxzmm6qjfwkkn3mnzn1fpmcp23fpbk74bi8p540q1nzccqj0v"))))
+         "039qi5x9sa1mjzinimxhiwzj8lxn5d5l33q6qhkjl0i5k70r9h75"))))
     (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'set-HOME
-           (lambda _ (setenv "HOME" "/tmp")))
-         (replace 'check
-           (lambda _
-             ;; Disable failing test.
-             (invoke "python" "-m" "pytest" "-k"
-                     "not test_pyqt_completion"))))))
     (propagated-inputs
      (list python-autopep8
            python-pydocstyle
            python-flake8
-           python-future
            python-jedi
            python-lsp-jsonrpc
            python-pluggy
            python-pycodestyle
            python-pyflakes
            python-rope
+           python-setuptools
            python-ujson
            python-yapf))
     (native-inputs
      (list python-coverage
            python-flaky
            python-matplotlib
-           python-mock
            python-numpy
            python-pandas
            python-pylint
            python-pytest
            python-pytest-cov
-           python-versioneer))
+           python-whatthepatch))
     (home-page "https://github.com/python-lsp/python-lsp-server")
     (synopsis "Python implementation of the Language Server Protocol")
     (description