diff mbox series

[bug#57036] gnu: Add emacs-mini-frame.

Message ID 20220807125312.1043149-1-contact@phfrohring.com
State Accepted
Headers show
Series [bug#57036] gnu: Add emacs-mini-frame. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Pierre-Henry Fröhring Aug. 7, 2022, 12:53 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-mini-frame): New variable.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Liliana Marie Prikler Aug. 7, 2022, 4:23 p.m. UTC | #1
Am Sonntag, dem 07.08.2022 um 14:53 +0200 schrieb Pierre-Henry
Fröhring:
> * gnu/packages/emacs-xyz.scm (emacs-mini-frame): New variable.
> ---
>  gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)
> 
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 3c1d322db3..1fc4442e90 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -31967,3 +31967,26 @@ (define-public emacs-vundo
>  tree to go back to previous buffer states.  To use vundo, type
> @kbd{M-x vundo RET} in
>  the buffer you want to undo.  An undo tree buffer should pop up.")
>      (license license:gpl3+)))
> +
> +(define-public emacs-mini-frame
> +  (package
> +    (name "emacs-mini-frame")
> +    (version "20220627.2041")
We don't do MELPA versions here.  Use git with git-version please. 
Refer to the "Version:" header in the source file to get the base
version.
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append
> "https://melpa.org/packages/mini-frame-"
> +                                  version ".el"))
> +              (sha256
> +               (base32
> +               
> "0xn5glw1159l7qg216yvi56clax9lbx4prrv28y1pkxyrqqwwl8d"))))
> +    (build-system emacs-build-system)
> +    (home-page "https://github.com/muffinmad/emacs-mini-frame")
> +    (synopsis "Show minibuffer in child frame")
> +    (description
> +     "Place minibuffer at the top of the current frame on read-from-
> minibuffer.
> +
> +@dfn{mini-frame-mode} makes an advice around read-from-minibuffer
> function to
> +create and show minibuffer-only child frame to accept input.
> @code{find-file}
> +and similar functions associated mini-buffers may appear at the
> center of the
> +screen and not at the bottom.")
> +    (license license:gpl3+)))
Cheers
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3c1d322db3..1fc4442e90 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31967,3 +31967,26 @@  (define-public emacs-vundo
 tree to go back to previous buffer states.  To use vundo, type @kbd{M-x vundo RET} in
 the buffer you want to undo.  An undo tree buffer should pop up.")
     (license license:gpl3+)))
+
+(define-public emacs-mini-frame
+  (package
+    (name "emacs-mini-frame")
+    (version "20220627.2041")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://melpa.org/packages/mini-frame-"
+                                  version ".el"))
+              (sha256
+               (base32
+                "0xn5glw1159l7qg216yvi56clax9lbx4prrv28y1pkxyrqqwwl8d"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/muffinmad/emacs-mini-frame")
+    (synopsis "Show minibuffer in child frame")
+    (description
+     "Place minibuffer at the top of the current frame on read-from-minibuffer.
+
+@dfn{mini-frame-mode} makes an advice around read-from-minibuffer function to
+create and show minibuffer-only child frame to accept input. @code{find-file}
+and similar functions associated mini-buffers may appear at the center of the
+screen and not at the bottom.")
+    (license license:gpl3+)))