diff mbox series

[bug#57033] gnu: Add emacs-vertico-posframe.

Message ID 20220807114318.979623-1-contact@phfrohring.com
State Accepted
Headers show
Series [bug#57033] gnu: Add emacs-vertico-posframe. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Pierre-Henry Fröhring Aug. 7, 2022, 11:43 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-vertico-posframe): New variable.
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Nicolas Goaziou Aug. 25, 2022, 12:09 p.m. UTC | #1
Hello,

Pierre-Henry Fröhring <contact@phfrohring.com> writes:

> * gnu/packages/emacs-xyz.scm (emacs-vertico-posframe): New variable.

Applied. Thank you.

> +    (description
> +     "@dfn{vertico} is an emacs package that provides a vertical
> +completion UI based on the default completion system.
> +@dfn{posframe} is an emacs package that provides a way to pop up a
> +frame at point.
> +@dfn{vertico-posframe} is an emacs package and a vertico extension
> +which provides a way to pop up a frame at point to show a vertical
> +completion UI.")

Nitpick: I used capitalization instead of @dfn markup.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3c1d322db3..863ce76f5b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31967,3 +31967,29 @@  (define-public emacs-vundo
 tree to go back to previous buffer states.  To use vundo, type @kbd{M-x vundo RET} in
 the buffer you want to undo.  An undo tree buffer should pop up.")
     (license license:gpl3+)))
+
+(define-public emacs-vertico-posframe
+  (package
+    (name "emacs-vertico-posframe")
+    (version "0.5.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://elpa.gnu.org/packages/vertico-posframe-" version
+                    ".tar"))
+              (sha256
+               (base32
+                "19lx6p06wkwfivxgswdljdsh9bgcd1b9zkzx426w3pwicdk0cvgg"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-posframe emacs-vertico))
+    (home-page "https://github.com/tumashu/vertico-posframe")
+    (synopsis "Pop up a frame at point to show vertical completion UI")
+    (description
+     "@dfn{vertico} is an emacs package that provides a vertical
+completion UI based on the default completion system.
+@dfn{posframe} is an emacs package that provides a way to pop up a
+frame at point.
+@dfn{vertico-posframe} is an emacs package and a vertico extension
+which provides a way to pop up a frame at point to show a vertical
+completion UI.")
+    (license license:gpl3+)))