diff mbox series

[bug#56995,2/2] gnu: ugrep: Use gexps.

Message ID 20220806053750.184243-2-kiasoc5@disroot.org
State Accepted
Headers show
Series [bug#56995,1/2] gnu: ugrep: Add zstd lib to inputs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

kiasoc5 Aug. 6, 2022, 5:37 a.m. UTC
* gnu/packages/search.scm (ugrep)[source]: Convert snippet to gexp.
[arguments]: Use gexps.
---
 gnu/packages/search.scm | 36 ++++++++++++++++++------------------
 1 file changed, 18 insertions(+), 18 deletions(-)

Comments

Liliana Marie Prikler Aug. 6, 2022, 2:41 p.m. UTC | #1
Am Samstag, dem 06.08.2022 um 01:37 -0400 schrieb kiasoc5:
> * gnu/packages/search.scm (ugrep)[source]: Convert snippet to gexp.
> [arguments]: Use gexps.
Pushed with a fix on the first patch and slightly modified ChangeLog.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 175a31cd5d..34dc6d5faf 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -32,6 +32,7 @@  (define-module (gnu packages search)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module (guix gexp)
   #:use-module (guix utils)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system perl)
@@ -681,14 +682,12 @@  (define-public ugrep
               (sha256
                (base32 "03b3lahc3zzsznaqnrk47f1cnd5jwakvwrkz0r4m2crk09cpfv57"))
               (file-name (git-file-name name version))
-              (modules '((guix build utils)))
-              (snippet
-               '(begin
-                  (delete-file-recursively "bin") ; pre-built executables
-                  (for-each delete-file (find-files "tests" "^archive\\..*"))
-                  (for-each delete-file (find-files "tests" "^.*\\.pdf$"))
-                  (for-each delete-file (find-files "tests" "^.*\\.class$"))
-                  #t))))
+              (snippet #~(begin
+                           (use-modules (guix build utils))
+                           (delete-file-recursively "bin") ; pre-built executables
+                           (for-each delete-file (find-files "tests" "^archive\\..*"))
+                           (for-each delete-file (find-files "tests" "^.*\\.pdf$"))
+                           (for-each delete-file (find-files "tests" "^.*\\.class$"))))))
     (build-system gnu-build-system)
     (inputs
      (list bzip2
@@ -698,18 +697,19 @@  (define-public ugrep
            pcre2
            zlib
            `(,zstd "lib"))
-    (arguments
-     `(#:tests? #f                  ; no way to rebuild the binary input files
+     (arguments
+      (list
+       #:tests? #f                  ; no way to rebuild the binary input files
        #:test-target "test"
        #:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'check-setup
-           (lambda _
-             ;; Unpatch shebangs in tests.
-             (substitute* '("tests/Hello.bat"
-                            "tests/Hello.sh")
-               (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
-    (home-page "https://github.com/Genivia/ugrep/")
+       #~(modify-phases %standard-phases
+           (add-before 'check 'check-setup
+             (lambda _
+               ;; Unpatch shebangs in tests.
+               (substitute* '("tests/Hello.bat"
+                              "tests/Hello.sh")
+                 (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
+     (home-page "https://github.com/Genivia/ugrep/")
     (synopsis "Faster grep with an interactive query UI")
     (description "Ugrep is a ultra fast searcher of file systems, text
 and binary files, source code, archives, compressed files, documents, and