diff mbox series

[bug#56999,1/4] gnu: Add phyml.

Message ID 20220805093306.21767-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#56999,1/4] gnu: Add phyml. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu Aug. 5, 2022, 9:33 a.m. UTC
* gnu/packages/bioinformatics.scm (phyml): New variable.
---
 gnu/packages/bioinformatics.scm | 37 +++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)


base-commit: 47a38d09696b309f6174b585465e621352444ddb

Comments

Ricardo Wurmus Aug. 8, 2022, 8:09 a.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> * gnu/packages/bioinformatics.scm (phyml): New variable.

Thanks for the patch.

> +     "@code{PhyML} is a software package that uses modern statistical approaches
> +to analyse alignments of nucleotide or amino acid sequences in a phylogenetic
> +framework.  The main tool in this package builds phylogenies under the maximum
> +likelihood criterion.  It implements a large number of substitution models coupled
> +with efficient options to search the space of phylogenetic tree topologies.  @code{
> +PhyTime} is another tool in the @code{PhyML} package that focuses on divergence
> +date estimation in a Bayesian setting.  The main strengths of @code{PhyTime} lie
> +in its ability to accommodate for uncertrainty in the placement of fossil
> +calibration and the use of realistic models of rate variation along the tree.
> +Finally, code{PhyREX} fits the spatial-Lambda-Fleming-Viot model to geo-referenced
> +genetic data.  This model is similar to the structured coalescent but assumes that
> +individuals are distributed along a spatial continuum rather than discrete demes.
> +@code{PhyREX} can be used to estimate population densities and rates of dispersal.
> +Its output can be processed by treeannotator (from the @code{BEAST} package) as
> +well as @code{SPREAD}.")

The description mentions PhyTime and PhyREX, neither of which are
included in this package.  I’ll try to integrate this package with
the definitions of phyml-mpi, phyml-phyrex, and phyml-rf that you’ve
sent here.
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 00238531db..fa91f48569 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9068,6 +9068,43 @@  (define-public phylip
 programs for inferring phylogenies (evolutionary trees).")
     (license license:bsd-2)))
 
+(define-public phyml
+  (package
+    (name "phyml")
+    (version "3.3.20220408")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/stephaneguindon/phyml")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "03hdqmnsgnzkcrp9r9ajdfkj33jgq4b86kra8ssjlrph65y344sa"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     (list automake
+           autoconf))
+    (home-page "https://github.com/stephaneguindon/phyml")
+    (synopsis "Programs for working on SAM/BAM files")
+    (description
+     "@code{PhyML} is a software package that uses modern statistical approaches
+to analyse alignments of nucleotide or amino acid sequences in a phylogenetic
+framework.  The main tool in this package builds phylogenies under the maximum
+likelihood criterion.  It implements a large number of substitution models coupled
+with efficient options to search the space of phylogenetic tree topologies.  @code{
+PhyTime} is another tool in the @code{PhyML} package that focuses on divergence
+date estimation in a Bayesian setting.  The main strengths of @code{PhyTime} lie
+in its ability to accommodate for uncertrainty in the placement of fossil
+calibration and the use of realistic models of rate variation along the tree.
+Finally, code{PhyREX} fits the spatial-Lambda-Fleming-Viot model to geo-referenced
+genetic data.  This model is similar to the structured coalescent but assumes that
+individuals are distributed along a spatial continuum rather than discrete demes.
+@code{PhyREX} can be used to estimate population densities and rates of dispersal.
+Its output can be processed by treeannotator (from the @code{BEAST} package) as
+well as @code{SPREAD}.")
+    (license license:gpl3)))
+
 (define-public imp
   (package
     (name "imp")