diff mbox series

[bug#56984,V3] gnu: ugrep: Use gexps and add zstd lib to inputs.

Message ID 20220805050408.342881-1-kiasoc5@disroot.org
State Accepted
Headers show
Series [bug#56984,V3] gnu: ugrep: Use gexps and add zstd lib to inputs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

kiasoc5 Aug. 5, 2022, 5:04 a.m. UTC
* gnu/packages/search.scm (ugrep)[snippets]: Remove trailing #t.
[snippets]: Use gexps.
[arguments]: Likewise.
[inputs]: Add zstd lib.
---
 gnu/packages/search.scm | 28 +++++++++++++++-------------
 1 file changed, 15 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index db5579a708..620c8dbe1f 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -32,6 +32,7 @@  (define-module (gnu packages search)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module (guix gexp)
   #:use-module (guix utils)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system perl)
@@ -687,8 +688,7 @@  (define-public ugrep
                   (delete-file-recursively "bin") ; pre-built executables
                   (for-each delete-file (find-files "tests" "^archive\\..*"))
                   (for-each delete-file (find-files "tests" "^.*\\.pdf$"))
-                  (for-each delete-file (find-files "tests" "^.*\\.class$"))
-                  #t))))
+                  (for-each delete-file (find-files "tests" "^.*\\.class$"))))))
     (build-system gnu-build-system)
     (inputs
      (list bzip2
@@ -696,18 +696,20 @@  (define-public ugrep
            lz4
            lzip ;; lzma
            pcre2
-           zlib))
+           zlib
+           zstd))
     (arguments
-     `(#:tests? #f                  ; no way to rebuild the binary input files
-       #:test-target "test"
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'check-setup
-           (lambda _
-             ;; Unpatch shebangs in tests.
-             (substitute* '("tests/Hello.bat"
-                            "tests/Hello.sh")
-               (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
+     (list
+      #:tests? #f                  ; no way to rebuild the binary input files
+      #:test-target "test"
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'check-setup
+            (lambda _
+              ;; Unpatch shebangs in tests.
+              (substitute* '("tests/Hello.bat"
+                             "tests/Hello.sh")
+                (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
     (home-page "https://github.com/Genivia/ugrep/")
     (synopsis "Faster grep with an interactive query UI")
     (description "Ugrep is a ultra fast searcher of file systems, text