diff mbox series

[bug#56984,V2] gnu: openh264: Update to 2.3.0 and use gexps.

Message ID 20220805044452.323170-1-kiasoc5@disroot.org
State Accepted
Headers show
Series [bug#56984,V2] gnu: openh264: Update to 2.3.0 and use gexps. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

kiasoc5 Aug. 5, 2022, 4:44 a.m. UTC
* gnu/packages/video.scm (openh264): Update to 2.3.0.
[arguments]: Use gexps.
---
 gnu/packages/video.scm | 19 +++++++++++--------
 1 file changed, 11 insertions(+), 8 deletions(-)

Comments

宋文武 Aug. 10, 2022, 8:29 a.m. UTC | #1
kiasoc5 <kiasoc5@disroot.org> writes:

> * gnu/packages/video.scm (openh264): Update to 2.3.0.
> [arguments]: Use gexps.
> ---
>  gnu/packages/video.scm | 19 +++++++++++--------
>  1 file changed, 11 insertions(+), 8 deletions(-)

I changed '(assoc-ref %outputs "out")' to '#$output'.

Pushed now, thank you for the patch and ( for the review!
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 04049fd9c8..b9e2c54eb7 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3940,7 +3940,7 @@  (define-public intel-vaapi-driver
 (define-public openh264
   (package
     (name "openh264")
-    (version "2.1.1")
+    (version "2.3.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -3949,17 +3949,20 @@  (define-public openh264
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0ffav46pz3sbj92nipd62z03fibyqgclfq9w8lgr80s6za6zdk5s"))))
+                "1yr6nsjpnazq4z6dvjfyanljwgwnyjh3ddxa0sq6hl9qc59yq91r"))))
     (build-system gnu-build-system)
     (native-inputs
      (list nasm python))
     (arguments
-     '(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
-                          "CC=gcc")
-       #:test-target "test"
-       #:phases (modify-phases %standard-phases
-                  ;; no configure script
-                  (delete 'configure))))
+     (list
+      #:make-flags
+      #~(list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+                             "CC=gcc")
+      #:test-target "test"
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; no configure script
+          (delete 'configure))))
     (home-page "https://www.openh264.org/")
     (synopsis "H264 decoder library")
     (description