diff mbox series

[bug#56990,v1,2/5] gnu: bqn: Add bqn-bytecode-sources.

Message ID 20220805022023.5044-2-yewscion@gmail.com
State Accepted
Headers show
Series [bug#56989,v1,1/5] gnu: bqn: Add bqn.scm and dbqn package. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Christopher Rodriguez Aug. 5, 2022, 2:20 a.m. UTC
---
 gnu/packages/bqn.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bqn.scm b/gnu/packages/bqn.scm
index 53e2f0a057..221ed9eaaa 100644
--- a/gnu/packages/bqn.scm
+++ b/gnu/packages/bqn.scm
@@ -90,3 +90,38 @@  (define-public dbqn
       (description "BQN implementation based on dzaima/APL.")
       (home-page "https://github.com/dzaima/BQN")
       (license license:expat))))
+(define bqn-bytecode-sources
+  (let* ((tag "0")
+         (revision "1")
+         (commit "e219af48401473a7bac49bdd8b89d69082cf5dd8")
+         (hash "0r6pa9lscl2395g4xlvmg90vpdsjzhin4f1r0s7brymmpvmns2yc")
+         (version (git-version tag revision commit)))
+    (package
+      (name "bqn-bytecode-sources")
+      (version version)
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/mlochbaum/BQN")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  hash))))
+      (outputs '("out"))
+      (build-system copy-build-system) ;This package pulls down needed source
+      ;; files for CBQN's build process. They
+      ;; will be compiled during that build;
+      ;; none of them are prebuilt binaries.
+      (arguments
+       (list #:install-plan '(list (list "src/" "share/src"
+                                         #:exclude '("README.txt" "doc/"))
+                                   (list "test/" "share/test"
+                                         #:exclude '("README.txt")))))
+      (synopsis "Official BQN sources in BQN")
+      (description
+       "The collection of sources needed for building a
+BQN-based BQN implementation.  These are included here for bootstrapping
+purposes.")
+      (home-page "https://github.com/mlochbaum/BQN.git")
+      (license license:gpl3))))