diff mbox series

[bug#56908,v2] gnu: packages: Add gopls.

Message ID 20220804173545.2274-1-paren@disroot.org
State Accepted
Headers show
Series [bug#56908,v2] gnu: packages: Add gopls. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( Aug. 4, 2022, 5:35 p.m. UTC
* gnu/packages/golang.scm (gopls): New variable.
---
 gnu/packages/golang.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)

Comments

\( Aug. 4, 2022, 5:37 p.m. UTC | #1
This improved patch doesn't use propagated-inputs or modify-inputs (since
x-tools doesn't have any inputs anyway).

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1ce55875d8..68fd8630a2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -35,6 +35,7 @@ 
 ;;; Copyright © 2021 Lu Hui <luhux76@gmail.com>
 ;;; Copyright © 2022 Pier-Hugues Pellerin <phpellerin@gmail.com>
 ;;; Copyright © 2022 muradm <mail@muradm.net>
+;;; Copyright © 2022 ( <paren@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -9891,3 +9892,19 @@  (define-public go-github-com-sourcegraph-jsonrpc2
     (description
      "Package jsonrpc2 provides a Go implementation of JSON-RPC 2.0.")
     (license license:expat)))
+
+(define-public gopls
+  (package
+   (inherit go-golang-org-x-tools)
+   (name "gopls")
+   (arguments
+    (list #:unpack-path "golang.org/x/tools"
+          #:import-path "golang.org/x/tools/gopls"
+          #:install-source? #f))
+   (inputs (list go-golang-org-x-sync))
+   (synopsis "Go language server implementation")
+   (description
+    "This package provides the @acronym{LSP, Language Server Protocol}
+server implementation for the Go programming language. It provides
+on-the-fly code linting, formatting, completion, and introspection for
+Go code in text editors supporting LSP.")))