diff mbox series

[bug#55903,v6,24/41] gnu: Add go-github-com-protonmail-go-crypto.

Message ID 20220804171047.24424-24-paren@disroot.org
State New
Headers show
Series [bug#55903,v6,01/41] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

\( Aug. 4, 2022, 5:10 p.m. UTC
From: "(unmatched-parenthesis" <paren@disroot.org>

* gnu/packages/golang.scm (go-github-com-protonmail-go-crypto): New variable.
---
 gnu/packages/golang.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4532d9f94e..aaeb42e95b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10547,3 +10547,35 @@  (define-public go-github-com-emersion-go-imap-sortthread
      "The sortthread package implements message sorting and threading for
 @code{go-github-com-emersion-go-imap}.")
     (license license:expat)))
+
+(define-public go-github-com-protonmail-go-crypto
+  (package
+    (name "go-github-com-protonmail-go-crypto")
+    (version "0.0.0-20220623141421-5afb4c282135")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ProtonMail/go-crypto")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "05qxdbn8wdk901z5kw2r3jdrag58nxlcsy0p8xd6rq0d71sw94wy"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/ProtonMail/go-crypto"
+           #:tests? #f ; Source-only package.
+           #:phases
+           #~(modify-phases %standard-phases
+               ;; Source-only package.
+               (delete 'build))))
+    (propagated-inputs (list go-golang-org-x-crypto))
+    (home-page "https://github.com/ProtonMail/go-crypto")
+    (synopsis "Fork of golang.org/x/crypto with up-to-date OpenPGP
+implementation")
+    (description
+     "The crypto package provides cryptography for Go.  This version of the
+package is a fork that adds a more up-to-date OpenPGP implementation.  It
+is completely backwards compatible with
+@url{golang.org/x/crypto,the official package}.")
+    (license license:bsd-3)))