diff mbox series

[bug#56950] gnu: Add r-phylotools.

Message ID 20220803124919.7992-1-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#56950] gnu: Add r-phylotools. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu Aug. 3, 2022, 12:49 p.m. UTC
* gnu/packages/cran.scm (r-phylotools): New variable.
---
 gnu/packages/cran.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: c4e58c119d637ef434c4b52437f677dfb69eb091

Comments

Ricardo Wurmus Aug. 3, 2022, 1:27 p.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> * gnu/packages/cran.scm (r-phylotools): New variable.

This was already added with commit 20f9473532dd288c536581df2573ece2079f7a27.
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 094dd4e449..e90a4a9b08 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1376,6 +1376,29 @@  (define-public r-pheatmap
 control over dimensions and appearance.")
     (license license:gpl2+)))
 
+(define-public r-phylotools
+  (package
+    (name "r-phylotools")
+    (version "0.2.2")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "phylotools" version))
+              (sha256
+               (base32
+                "1dhk1ncp5zi4zl1xfnjz64v983dm7bq7iimfjin80j0bdcpps44w"))))
+    (properties `((upstream-name . "phylotools")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-ape))
+    (home-page "https://github.com/helixcn/phylotools")
+    (synopsis "Phylogenetic tools for eco-phylogenetics")
+    (description
+     "This package @code{phylotool} provides a collection of tools for building
+@dfn{RAxML} (Randomized Axelerated Maximum Likelihood) supermatrix using
+@code{PHYLIP} or aligned @code{FASTA} files.  These functions will be useful for
+building large dfn{phylogenies} (history of the evolution of a species or group)
+using multiple markers.")
+    (license license:gpl2)))
+
 (define-public r-pnwcolors
   (package
     (name "r-pnwcolors")