diff mbox series

[bug#56897] gnu: Add emacs-super-save.

Message ID 20220802200322.8497-1-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#56897] gnu: Add emacs-super-save. | expand

Commit Message

Nicolas Graves Aug. 2, 2022, 8:03 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-super-save): New variable.
---
 gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Nicolas Goaziou Aug. 25, 2022, 10:32 a.m. UTC | #1
Hello,

Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-super-save): New variable.

Applied with the changes below. Thank you.

> +(define-public emacs-super-save
> +  (package
> +    (name "emacs-super-save")
> +    (version "0.3.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +             "https://stable.melpa.org/packages/super-save-" version
> +             ".el"))

I used Github as upstream because MELPA does not provide stable
tarballs.

> +       (sha256
> +        (base32
> +         "12znjlpk3b3bkd1cvi922r5nn9r9rxahvmcysrdvdv2ckwdff5ch"))))
> +    (build-system emacs-build-system)
> +    (home-page "https://github.com/bbatsov/super-save")
> +    (synopsis "Auto-save buffers, based on your activity.")

I removed the full stop at the end of the synopsis.

> +    (description "This package implements auto-saving of buffers when they
> +lose focus.")

I expounded the description a bit.

> +    (license license:gpl3)))

License is actually gpl3+.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 408aaf57d2..12597b3fa4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27987,6 +27987,26 @@  (define-public emacs-ssh-agency
 passphrase until the first time you push to a remote.")
     (license license:gpl3+)))
 
+(define-public emacs-super-save
+  (package
+    (name "emacs-super-save")
+    (version "0.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://stable.melpa.org/packages/super-save-" version
+             ".el"))
+       (sha256
+        (base32
+         "12znjlpk3b3bkd1cvi922r5nn9r9rxahvmcysrdvdv2ckwdff5ch"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/bbatsov/super-save")
+    (synopsis "Auto-save buffers, based on your activity.")
+    (description "This package implements auto-saving of buffers when they
+lose focus.")
+    (license license:gpl3)))
+
 (define-public emacs-tao-theme
   (let ((commit "468ee4f6ba7afb9dbfc8855ae2c333cb16ca4408")
         (revision "1"))