diff mbox series

[bug#56881,v2] gnu: Add emacs-consult-yasnippet.

Message ID 20220802125502.22025-1-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#56881,v2] gnu: Add emacs-consult-yasnippet. | expand

Commit Message

Nicolas Graves Aug. 2, 2022, 12:55 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-consult-yasnippet): New variable.
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Nicolas Goaziou Aug. 25, 2022, 10:30 a.m. UTC | #1
Hello,

Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-consult-yasnippet): New variable.

Applied with the changes below. Thank you.

> +(define-public emacs-consult-yasnippet
> +  (let ((commit "ae0450889484f23dc4ec37518852a2c61b89f184")
> +        (revision "0"))
> +    (package
> +      (name "emacs-consult-yasnippet")
> +      (version (git-version "0" revision commit))

Base version is 0.2 according to main file.

> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/mohkale/consult-yasnippet")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32 "13hmmsnmh32vafws61sckzzy354rq0nslqpyzhw97iwvn0fpsa35"))))
> +      (build-system emacs-build-system)
> +      (propagated-inputs (list emacs-consult emacs-yasnippet))
> +      (home-page "https://github.com/mohkale/consult-yasnippet")
> +      (synopsis "Consulting-read interface for yasnippet")
> +      (description
> +       "This package allows you to expand @code{emacs-yasnippet} snippets
> +through a completing-read interface. It supports previewing the
> current

I added two spaces between the two sentences, per Texinfo requirements.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 702378c206..408aaf57d2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9154,6 +9154,32 @@  (define-public emacs-consult-eglot
 call.")
    (license license:gpl3+)))
 
+(define-public emacs-consult-yasnippet
+  (let ((commit "ae0450889484f23dc4ec37518852a2c61b89f184")
+        (revision "0"))
+    (package
+      (name "emacs-consult-yasnippet")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/mohkale/consult-yasnippet")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "13hmmsnmh32vafws61sckzzy354rq0nslqpyzhw97iwvn0fpsa35"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-consult emacs-yasnippet))
+      (home-page "https://github.com/mohkale/consult-yasnippet")
+      (synopsis "Consulting-read interface for yasnippet")
+      (description
+       "This package allows you to expand @code{emacs-yasnippet} snippets
+through a completing-read interface. It supports previewing the current
+snippet expansion and overwriting the marked region with a new snippet
+completion.")
+      (license license:gpl3+))))
+
 (define-public emacs-marginalia
   (package
     (name "emacs-marginalia")