diff mbox series

[bug#56881] gnu: Add emacs-consult-yasnippet.

Message ID 20220802113957.29792-1-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#56881] gnu: Add emacs-consult-yasnippet. | expand

Commit Message

Nicolas Graves Aug. 2, 2022, 11:39 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-consult-yasnippet): New variable.
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

\( Aug. 2, 2022, 11:48 a.m. UTC | #1
On Tue Aug 2, 2022 at 12:39 PM BST, Nicolas Graves via Guix-patches via wrote:
> +      (description
> +"This package implements allows you to expand yasnippet snippets through a\
> +completing-read interface. It supports previewing the current snippet\
> +expansion and overwriting the marked region with a new snippet completion.\
> +")

I think this slightly amended version is better:

> +      (description
> +       "This package allows you to expand @code{emacs-yasnippet} snippets
> +through a completing-read interface. It supports previewing the current
> +snippet expansion and overwriting the marked region with a new snippet
> +completion.")

    -- (
Nicolas Graves Aug. 2, 2022, 11:59 a.m. UTC | #2
Indeed. Should I sent an updated patch ? 

Thanks!
\( Aug. 2, 2022, 12:07 p.m. UTC | #3
On Tue Aug 2, 2022 at 12:59 PM BST, Nicolas Graves via Guix-patches via wrote:
> Indeed. Should I sent an updated patch ? 

Yeah.

ʃ # after applying my change
ʃ git add -p
ʃ git commit --amend
ʃ git send-email --to=56881@debbugs.gnu.org -v2

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 702378c206..b2634de8ee 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9154,6 +9154,32 @@  (define-public emacs-consult-eglot
 call.")
    (license license:gpl3+)))
 
+(define-public emacs-consult-yasnippet
+  (let ((commit "ae0450889484f23dc4ec37518852a2c61b89f184")
+        (revision "0"))
+    (package
+      (name "emacs-consult-yasnippet")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/mohkale/consult-yasnippet")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "13hmmsnmh32vafws61sckzzy354rq0nslqpyzhw97iwvn0fpsa35"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-consult emacs-yasnippet))
+      (home-page "https://github.com/mohkale/consult-yasnippet")
+      (synopsis "Consulting-read interface for yasnippet")
+      (description
+"This package implements allows you to expand yasnippet snippets through a\
+completing-read interface. It supports previewing the current snippet\
+expansion and overwriting the marked region with a new snippet completion.\
+")
+      (license license:gpl3+))))
+
 (define-public emacs-marginalia
   (package
     (name "emacs-marginalia")