diff mbox series

[bug#56859,v2] gnu: xdg-desktop-portal-wlr: Change elogind to basu for sd-bus.

Message ID 20220801053520.2449-1-mail@muradm.net
State New
Headers show
Series [bug#56859,v2] gnu: xdg-desktop-portal-wlr: Change elogind to basu for sd-bus. | expand

Commit Message

muradm Aug. 1, 2022, 5:35 a.m. UTC
* gnu/packages/freedesktop.scm (xdg-desktop-portal-wlr):
[inputs]: Change elogind to basu.
[arguments]: Specify "-Dsd-bus-provider=basu" explicitly.

xdg-desktop-portal-wlr requires only sd-bus which is now
available via basu as standalone.
---
 gnu/packages/freedesktop.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index cde7156383..1a30091da0 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2408,7 +2408,7 @@  (define-public xdg-desktop-portal-wlr
     (arguments
      `(#:configure-flags
        '("-Dsystemd=disabled"
-         "-Dsd-bus-provider=libelogind")
+         "-Dsd-bus-provider=basu")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'hardcode-binaries
@@ -2426,8 +2426,8 @@  (define-public xdg-desktop-portal-wlr
                   (string-append "execvp(\"" sh)))))))))
     (native-inputs
      (list cmake pkg-config))
-    (inputs (list elogind
-                  bash-minimal
+    (inputs (list bash-minimal
+                  basu
                   grim
                   iniparser
                   libinih