diff mbox series

[bug#56859] gnu: xdg-desktop-portal-wlr: Change elogind to basu for sd-bus.

Message ID 20220731155038.30945-1-mail@muradm.net
State New
Headers show
Series [bug#56859] gnu: xdg-desktop-portal-wlr: Change elogind to basu for sd-bus. | expand

Commit Message

muradm July 31, 2022, 3:50 p.m. UTC
* gnu/packages/freedesktop.scm (xdg-desktop-portal-wlr):
[inputs]: Change elogind to basu.
[arguments]: Specify "-Dsd-bus-provider=basu" explicitly.
---
 gnu/packages/freedesktop.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

M July 31, 2022, 5:38 p.m. UTC | #1
On 31-07-2022 17:50, muradm wrote:
> * gnu/packages/freedesktop.scm (xdg-desktop-portal-wlr):
> [inputs]: Change elogind to basu.
> [arguments]: Specify "-Dsd-bus-provider=basu" explicitly.

What's the reason for the switch?

Greetings,
Maxime
\( July 31, 2022, 9:45 p.m. UTC | #2
On Sun Jul 31, 2022 at 6:38 PM BST, Maxime Devos wrote:
> What's the reason for the switch?
Fewer dependencies (we include only the sd-bus library without the whole
of elogind), and it means eventually desktop users won't ever need elogind
to even exist in their store. (I think this is the reason. I'm not certain,
and there may be something more important, like some incompatibility with
seatd.)

    -- (
M July 31, 2022, 11:13 p.m. UTC | #3
On 31-07-2022 23:45, ( wrote:
> On Sun Jul 31, 2022 at 6:38 PM BST, Maxime Devos wrote:
>> What's the reason for the switch?
> Fewer dependencies (we include only the sd-bus library without the whole
> of elogind), and it means eventually desktop users won't ever need elogind
> to even exist in their store. (I think this is the reason. I'm not certain,
> and there may be something more important, like some incompatibility with
> seatd.)
>
>      -- (

That's interesting but sounds very non-specific to 
xdg-desktop-portal-wlr; I think this would be better to propose on 
guix-devel@ to switch elogind->basu for _all_ dependents, not only 
xdg-desktop-portal-wlr -- the latter would increate the closure, not 
reduce it, because other installed packages would still use elogind.

Greetings,
Maxime.
M July 31, 2022, 11:32 p.m. UTC | #4
On 01-08-2022 01:13, Maxime Devos wrote:
>
> On 31-07-2022 23:45, ( wrote:
>> On Sun Jul 31, 2022 at 6:38 PM BST, Maxime Devos wrote:
>>> What's the reason for the switch?
>> Fewer dependencies (we include only the sd-bus library without the whole
>> of elogind), and it means eventually desktop users won't ever need 
>> elogind
>> to even exist in their store. (I think this is the reason. I'm not 
>> certain,
>> and there may be something more important, like some incompatibility 
>> with
>> seatd.)
>>
>>      -- (
>
> That's interesting but sounds very non-specific to 
> xdg-desktop-portal-wlr; I think this would be better to propose on 
> guix-devel@ to switch elogind->basu for _all_ dependents, not only 
> xdg-desktop-portal-wlr -- the latter would increate the closure, not 
> reduce it, because other installed packages would still use elogind.

Additionally, the reason should have been mentioned in the commit message.

Greetings,
Maxime.
muradm Aug. 1, 2022, 4:55 a.m. UTC | #5
Hi,

Regarding switching, I don't think it is very straight forward
to switch elogind with basu. Issue is that elogind "also" includes
sd-bus. Dependents may require either sd-bus and/or other parts
of elogind. Those who require sd-bus only to interface with bus
could be switched to basu gradually. Most likely this will be
suitable for "minimalist" applications.

I.e. basu is a drop-in replacement for those require sd-bus only,
but not whole elogind.

Thanks in advance,
muradm

Maxime Devos <maximedevos@telenet.be> writes:

> [[PGP Signed Part:Undecided]]
>
> On 01-08-2022 01:13, Maxime Devos wrote:
>>
>> On 31-07-2022 23:45, ( wrote:
>>> On Sun Jul 31, 2022 at 6:38 PM BST, Maxime Devos wrote:
>>>> What's the reason for the switch?
>>> Fewer dependencies (we include only the sd-bus library without 
>>> the whole
>>> of elogind), and it means eventually desktop users won't ever 
>>> need
>>> elogind
>>> to even exist in their store. (I think this is the reason. I'm 
>>> not
>>> certain,
>>> and there may be something more important, like some
>>> incompatibility with
>>> seatd.)
>>>
>>>      -- (
>>
>> That's interesting but sounds very non-specific to
>> xdg-desktop-portal-wlr; I think this would be better to propose 
>> on
>> guix-devel@ to switch elogind->basu for _all_ dependents, not 
>> only
>> xdg-desktop-portal-wlr -- the latter would increate the 
>> closure, not
>> reduce it, because other installed packages would still use 
>> elogind.
>
> Additionally, the reason should have been mentioned in the 
> commit message.
>
> Greetings,
> Maxime.
>
> [2. OpenPGP public key --- application/pgp-keys; 
> OpenPGP_0x49E3EE22191725EE.asc]...
>
> [[End of PGP Signed Part]]
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index cde7156383..1a30091da0 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2408,7 +2408,7 @@  (define-public xdg-desktop-portal-wlr
     (arguments
      `(#:configure-flags
        '("-Dsystemd=disabled"
-         "-Dsd-bus-provider=libelogind")
+         "-Dsd-bus-provider=basu")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'hardcode-binaries
@@ -2426,8 +2426,8 @@  (define-public xdg-desktop-portal-wlr
                   (string-append "execvp(\"" sh)))))))))
     (native-inputs
      (list cmake pkg-config))
-    (inputs (list elogind
-                  bash-minimal
+    (inputs (list bash-minimal
+                  basu
                   grim
                   iniparser
                   libinih