diff mbox series

[bug#56858] gnu: libcgroup: Update to 2.0.2.

Message ID 20220731152938.28770-1-mail@muradm.net
State Accepted
Headers show
Series [bug#56858] gnu: libcgroup: Update to 2.0.2. | expand

Commit Message

muradm July 31, 2022, 3:29 p.m. UTC
* gnu/packages/linux.scm (libcgroup): Update to 2.0.2.
[source]: Project migrated to github.
---
 gnu/packages/linux.scm | 11 +++++------
 1 file changed, 5 insertions(+), 6 deletions(-)

Comments

\( July 31, 2022, 9:48 p.m. UTC | #1
Hi!

On Sun Jul 31, 2022 at 4:29 PM BST, muradm wrote:
> +    (home-page "https://github.com/libcgroup/libcgroup")
Put home-page under inputs and above synopsis, where it was before.

>         (method url-fetch)
> -       (uri (string-append
> -             "mirror://sourceforge/libcg/" name "/"
> -             version "/" name "-" version ".tar.bz2"))
> +       (uri (string-append home-page "/releases/download/v"
> +                           version "/" name "-" version ".tar.gz"))
Since we're using github now, we likely want to use git-fetch here.
I've been told Github releases are volatile.

    -- (
muradm Aug. 1, 2022, 5:42 a.m. UTC | #2
"(" <paren@disroot.org> writes:

> Hi!
>
> On Sun Jul 31, 2022 at 4:29 PM BST, muradm wrote:
>> +    (home-page "https://github.com/libcgroup/libcgroup")
> Put home-page under inputs and above synopsis, where it was 
> before.
>

Is there a guideline where home-page should be? I find it more
DRY when reusing.

>>         (method url-fetch)
>> -       (uri (string-append
>> -             "mirror://sourceforge/libcg/" name "/"
>> -             version "/" name "-" version ".tar.bz2"))
>> +       (uri (string-append home-page "/releases/download/v"
>> +                           version "/" name "-" version 
>> ".tar.gz"))
> Since we're using github now, we likely want to use git-fetch 
> here.
> I've been told Github releases are volatile.
>
>     -- (

Their repo is not suitable for building from, instead
they release sources manually.
\( Aug. 1, 2022, 9:02 a.m. UTC | #3
On Mon Aug 1, 2022 at 6:42 AM BST, muradm wrote:
> Is there a guideline where home-page should be? I find it more
> DRY when reusing.
Almost every package in Guix puts it directly above synopsis, though
you do have a point about DRY.

> Their repo is not suitable for building from, instead
> they release sources manually.
Looks okay to me: <https://github.com/libcgroup/libcgroup/tree/v2.0.2>
But there is a problem with vendoring googletest, it seems. You'll want
to use the system's googletest, and (recursive? #t) in the git-reference
to clone the tests repo. Also, the tarball seems to contain pregenerated
autotools files, which are discouraged by Guix.


    -- (
\( Aug. 1, 2022, 9:06 a.m. UTC | #4
On Mon Aug 1, 2022 at 10:02 AM BST, ( via Guix-patches via wrote:
> (recursive? #t) in the git-reference to clone the tests repo.
Alternatively, write an <origin> for the tests repo, then use
that as an input for the libcgroup package.

    -- (
muradm Aug. 1, 2022, 1:13 p.m. UTC | #5
Previous version was also built from sources.

I didn't find it feasible to battle with bootstraping
for this version either. Tests are very intrusive and/or
containerized with lxc. So yeah, as per their process, there
are tons of things to be done manually from bootstraping.

May be sometime in the future if they will move to more
modern project layout, that could become feasible.

"(" <paren@disroot.org> writes:

> On Mon Aug 1, 2022 at 6:42 AM BST, muradm wrote:
>> Is there a guideline where home-page should be? I find it more
>> DRY when reusing.
> Almost every package in Guix puts it directly above synopsis, 
> though
> you do have a point about DRY.
>
>> Their repo is not suitable for building from, instead
>> they release sources manually.
> Looks okay to me: 
> <https://github.com/libcgroup/libcgroup/tree/v2.0.2>
> But there is a problem with vendoring googletest, it seems. 
> You'll want
> to use the system's googletest, and (recursive? #t) in the 
> git-reference
> to clone the tests repo. Also, the tarball seems to contain 
> pregenerated
> autotools files, which are discouraged by Guix.
>
>
>     -- (
宋文武 Aug. 4, 2022, 5:55 a.m. UTC | #6
"(" <paren@disroot.org> writes:

> Hi!
>
> On Sun Jul 31, 2022 at 4:29 PM BST, muradm wrote:
>> +    (home-page "https://github.com/libcgroup/libcgroup")
> Put home-page under inputs and above synopsis, where it was before.
>
>>         (method url-fetch)
>> -       (uri (string-append
>> -             "mirror://sourceforge/libcg/" name "/"
>> -             version "/" name "-" version ".tar.bz2"))
>> +       (uri (string-append home-page "/releases/download/v"
>> +                           version "/" name "-" version ".tar.gz"))
> Since we're using github now, we likely want to use git-fetch here.
> I've been told Github releases are volatile.

Hello, I believe '/releases' are okay, since they are uploaded manual by
the owner, the unstable ones are under '/archive' which are
auto-generated tarballs for tags.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 906303175d..bcb2bb284a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8146,15 +8146,15 @@  (define-public fbcat
 (define-public libcgroup
   (package
     (name "libcgroup")
-    (version "0.41")
+    (version "2.0.2")
+    (home-page "https://github.com/libcgroup/libcgroup")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append
-             "mirror://sourceforge/libcg/" name "/"
-             version "/" name "-" version ".tar.bz2"))
+       (uri (string-append home-page "/releases/download/v"
+                           version "/" name "-" version ".tar.gz"))
        (sha256
-        (base32 "0lgvyq37gq84sk30sg18admxaj0j0p5dq3bl6g74a1ppgvf8pqz4"))))
+        (base32 "1y0c9ncsawamj77raiw6qkbm5cdsyvhjb2mvgma1kxmgw0r3pxlf"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f))
@@ -8162,7 +8162,6 @@  (define-public libcgroup
      (list bison flex))
     (inputs
      (list linux-pam))
-    (home-page "https://sourceforge.net/projects/libcg/")
     (synopsis "Control groups management tools")
     (description "Control groups is Linux kernel method for process resource
 restriction, permission handling and more.  This package provides userspace